summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.2.ebuild21
-rw-r--r--sys-devel/llvm/metadata.xml1
3 files changed, 20 insertions, 8 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 633ce2d51d4c..224329a3ef11 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.104 2013/01/07 20:22:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.105 2013/01/17 13:44:07 voyageur Exp $
+
+ 17 Jan 2013; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.2.ebuild,
+ metadata.xml:
+ Provided pre-generated manpages with USE=-doc, fixes bug #448250 by Duncan
07 Jan 2013; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.2.ebuild,
llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-3.2.ebuild b/sys-devel/llvm/llvm-3.2.ebuild
index 936283120df7..8140d14cc211 100644
--- a/sys-devel/llvm/llvm-3.2.ebuild
+++ b/sys-devel/llvm/llvm-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.2.ebuild,v 1.3 2013/01/07 20:22:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.2.ebuild,v 1.4 2013/01/17 13:44:07 voyageur Exp $
EAPI=5
PYTHON_DEPEND="2"
@@ -8,7 +8,8 @@ inherit eutils flag-o-matic multilib toolchain-funcs python pax-utils
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.gz"
+SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.gz
+ !doc? ( http://dev.gentoo.org/~voyageur/distfiles/${P}-manpages.tar.bz2 )"
LICENSE="UoI-NCSA"
SLOT="0"
@@ -16,12 +17,12 @@ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux
IUSE="debug doc gold +libffi multitarget ocaml test udis86 vim-syntax"
DEPEND="dev-lang/perl
- dev-python/sphinx
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
+ doc? ( dev-python/sphinx )
gold? ( >=sys-devel/binutils-2.22[cxx] )
libffi? ( virtual/pkgconfig
virtual/libffi )
@@ -148,8 +149,10 @@ src_configure() {
src_compile() {
emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1
- emake -C docs -f Makefile.sphinx man
- use doc && emake -C docs -f Makefile.sphinx html
+ if use doc; then
+ emake -C docs -f Makefile.sphinx man html
+ fi
+ # emake -C docs -f Makefile.sphinx html
pax-mark m Release/bin/lli
if use test; then
@@ -162,8 +165,12 @@ src_compile() {
src_install() {
emake KEEP_SYMBOLS=1 DESTDIR="${D}" install
- doman docs/_build/man/*.1
- use doc && dohtml -r docs/_build/html/
+ if use doc; then
+ doman docs/_build/man/*.1
+ dohtml -r docs/_build/html/
+ else
+ doman "${WORKDIR}"/${P}-manpages/*.1
+ fi
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index e5a362b5c5b3..4428300ba5df 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -15,6 +15,7 @@
3. A compiler infrastructure - LLVM is also a collection of source code that implements the language and compilation strategy. The primary components of the LLVM infrastructure are a GCC-based C and C++ front-end, a link-time optimization framework with a growing set of global and interprocedural analyses and transformations, static back-ends for many popular (and some obscure) architectures, a back-end which emits portable C code, and a Just-In-Time compilers for several architectures.
4. LLVM does not imply things that you would expect from a high-level virtual machine. It does not require garbage collection or run-time code generation (In fact, LLVM makes a great static compiler!). Note that optional LLVM components can be used to build high-level virtual machines and other systems that need these services.</longdescription>
<use>
+ <flag name='doc'>Build and install the HTML documentation and regenerate the man pages</flag>
<flag name='gold'>Build the gold linker plugin</flag>
<flag name='llvm-gcc'>Build LLVM with <pkg>sys-devel/llvm-gcc</pkg></flag>
<flag name='multitarget'>Build all host targets (default: host only)</flag>