summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/bin-prot/ChangeLog10
-rw-r--r--dev-ml/bin-prot/bin-prot-1.3.0.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index dc152cbc2747..769e2f111440 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/bin-prot
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.7 2010/12/24 17:39:49 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.8 2011/02/22 15:10:34 aballier Exp $
+
+*bin-prot-1.3.0 (22 Feb 2011)
+
+ 22 Feb 2011; Alexis Ballier <aballier@gentoo.org> +bin-prot-1.3.0.ebuild:
+ version bump, by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355747, with
+ small modifications by me
24 Dec 2010; Alexis Ballier <aballier@gentoo.org> -bin-prot-1.2.23.ebuild:
remove old
diff --git a/dev-ml/bin-prot/bin-prot-1.3.0.ebuild b/dev-ml/bin-prot/bin-prot-1.3.0.ebuild
new file mode 100644
index 000000000000..2382b4657757
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-1.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.3.0.ebuild,v 1.1 2011/02/22 15:10:34 aballier Exp $
+
+EAPI=3
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://www.janestreet.com/ocaml/bin_prot-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-ml/findlib
+ >=dev-ml/ounit-1.0.2
+ >=dev-ml/type-conv-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-ml/ounit-1.0.2
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${PN}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}