summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/xterm/ChangeLog11
-rw-r--r--x11-terms/xterm/files/digest-xterm-207-r13
-rw-r--r--x11-terms/xterm/files/digest-xterm-212-r33
-rw-r--r--x11-terms/xterm/files/digest-xterm-213-r13
-rw-r--r--x11-terms/xterm/xterm-207-r1.ebuild107
-rw-r--r--x11-terms/xterm/xterm-212-r3.ebuild106
-rw-r--r--x11-terms/xterm/xterm-213-r1.ebuild106
7 files changed, 338 insertions, 1 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index d7ba382be586..7502fc3e1638 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-terms/xterm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.136 2006/05/31 11:19:17 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.137 2006/06/02 15:22:42 seemant Exp $
+
+*xterm-213-r1 (02 Jun 2006)
+*xterm-212-r3 (02 Jun 2006)
+*xterm-207-r1 (02 Jun 2006)
+
+ 02 Jun 2006; Seemant Kulleen <seemant@gentoo.org> +xterm-207-r1.ebuild,
+ +xterm-212-r3.ebuild, +xterm-213-r1.ebuild:
+ Change the depends to sys-libs/libutempter specifically, see bug #75943 and
+ bug #115533
*xterm-213 (31 May 2006)
diff --git a/x11-terms/xterm/files/digest-xterm-207-r1 b/x11-terms/xterm/files/digest-xterm-207-r1
new file mode 100644
index 000000000000..b51bac6a8751
--- /dev/null
+++ b/x11-terms/xterm/files/digest-xterm-207-r1
@@ -0,0 +1,3 @@
+MD5 3de8a3756c284a46a08c6d0308909486 xterm-207.tgz 745083
+RMD160 225aafce1de43212e0cd86da953e99a1a9121a05 xterm-207.tgz 745083
+SHA256 652f579171e6e8f73c13ab6b060d2447ae35ebfbd39a6002b7c05a1dfc0f7eb8 xterm-207.tgz 745083
diff --git a/x11-terms/xterm/files/digest-xterm-212-r3 b/x11-terms/xterm/files/digest-xterm-212-r3
new file mode 100644
index 000000000000..6d07057d24f9
--- /dev/null
+++ b/x11-terms/xterm/files/digest-xterm-212-r3
@@ -0,0 +1,3 @@
+MD5 d39ec47dbf846e0e7dddb354280c4074 xterm-212.tgz 764465
+RMD160 2808cdf3f550ef9df7e83a4844f3f4f64f0508a1 xterm-212.tgz 764465
+SHA256 bfd201600c0f0f3c3d9dcfe32fde1db333307a87a4453084bf55a7aa97b3b6ae xterm-212.tgz 764465
diff --git a/x11-terms/xterm/files/digest-xterm-213-r1 b/x11-terms/xterm/files/digest-xterm-213-r1
new file mode 100644
index 000000000000..157da7bbd716
--- /dev/null
+++ b/x11-terms/xterm/files/digest-xterm-213-r1
@@ -0,0 +1,3 @@
+MD5 20827d968ed7406d01b2125a84b7a2cd xterm-213.tgz 765077
+RMD160 a6419401b30bcdc56f710af8e0bfeba62c101736 xterm-213.tgz 765077
+SHA256 745ea1f97a8e1cb836802d9433f5f466076953eab915b06448383d40ed2df68e xterm-213.tgz 765077
diff --git a/x11-terms/xterm/xterm-207-r1.ebuild b/x11-terms/xterm/xterm-207-r1.ebuild
new file mode 100644
index 000000000000..6382f4907e12
--- /dev/null
+++ b/x11-terms/xterm/xterm-207-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-207-r1.ebuild,v 1.1 2006/06/02 15:22:42 seemant Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
+IUSE="truetype Xaw3d unicode toolbar doc"
+
+RDEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw )
+ virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ doc? ( sys-apps/groff )
+ sys-libs/libutempter"
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+pkg_setup() {
+ if has_version ">=x11-base/xorg-x11-7.0.0_rc1"; then
+ einfo "Found $(best_version x11-base/xorg-x11)."
+ NEWAPPDEFAULTS=1
+ DEFAULTS_DIR="/usr/$(get_libdir)/X11/app-defaults"
+ else
+ einfo "Not found xorg-x11 version 7."
+ NEWAPPDEFAULTS=0
+ DEFAULTS_DIR="/etc/X11/app-defaults"
+ fi
+}
+
+
+src_compile() {
+
+ filter-flags "-fstack-protector"
+
+ econf \
+ --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --enable-ansi-color \
+ --enable-88-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --disable-narrowproto \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ `use_enable toolbar` \
+ `use_enable truetype freetype` \
+ `use_enable unicode luit` `use_enable unicode mini-luit` \
+ `use_with Xaw3d` \
+ || die
+
+ emake || die "failed to compile xterm"
+
+ if use doc ; then
+ make ctlseqs.txt || die "failed to make documentation file"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* INSTALL* ctlseqs.txt
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" ${D}/etc/X11/app-defaults/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/UXTerm
+
+}
+
+pkg_preinst() {
+ # Prevent the terminfo files from being removed. These collide with ncurses
+ # provided terminfo files. So, now no more package collisions, yay!
+ touch ${ROOT}/usr/share/terminfo/v/vs100
+ touch ${ROOT}/usr/share/terminfo/x/x*
+}
diff --git a/x11-terms/xterm/xterm-212-r3.ebuild b/x11-terms/xterm/xterm-212-r3.ebuild
new file mode 100644
index 000000000000..f6c51d873b21
--- /dev/null
+++ b/x11-terms/xterm/xterm-212-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-212-r3.ebuild,v 1.1 2006/06/02 15:22:42 seemant Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype Xaw3d unicode toolbar doc"
+
+RDEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw
+ unicode? ( x11-apps/luit ) )
+ virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ sys-libs/libutempter"
+
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/groff )
+ || ( x11-proto/xproto virtual/x11 )"
+
+pkg_setup() {
+ if has_version "x11-libs/libX11"; then
+ DEFAULTS_DIR="/usr/share/X11/app-defaults"
+ else
+ DEFAULTS_DIR="/etc/X11/app-defaults"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/xterm-app-defaults-ref.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ local myconf=""
+
+ if has_version "x11-libs/libX11"; then
+ myconf="--disable-narrowproto"
+ fi
+
+ econf \
+ --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --enable-ansi-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ $(use_enable toolbar) \
+ $(use_enable truetype freetype) \
+ $(use_enable unicode luit) $(use_enable unicode mini-luit) \
+ $(use_with Xaw3d) \
+ ${myconf} \
+ || die
+
+ emake || die "failed to compile xterm"
+
+ if use doc ; then
+ make ctlseqs.txt || die "failed to make documentation file"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README{,.i18n} ctlseqs.txt xterm.log.html
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" ${D}${DEFAULTS_DIR}/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/UXTerm
+}
diff --git a/x11-terms/xterm/xterm-213-r1.ebuild b/x11-terms/xterm/xterm-213-r1.ebuild
new file mode 100644
index 000000000000..e4a1d2ef8236
--- /dev/null
+++ b/x11-terms/xterm/xterm-213-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-213-r1.ebuild,v 1.1 2006/06/02 15:22:42 seemant Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype Xaw3d unicode toolbar doc"
+
+RDEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw
+ unicode? ( x11-apps/luit ) )
+ virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ sys-libs/libutempter"
+
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/groff )
+ || ( x11-proto/xproto virtual/x11 )"
+
+pkg_setup() {
+ if has_version "x11-libs/libX11"; then
+ DEFAULTS_DIR="/usr/share/X11/app-defaults"
+ else
+ DEFAULTS_DIR="/etc/X11/app-defaults"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/xterm-app-defaults-ref.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ local myconf=""
+
+ if has_version "x11-libs/libX11"; then
+ myconf="--disable-narrowproto"
+ fi
+
+ econf \
+ --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --enable-ansi-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ $(use_enable toolbar) \
+ $(use_enable truetype freetype) \
+ $(use_enable unicode luit) $(use_enable unicode mini-luit) \
+ $(use_with Xaw3d) \
+ ${myconf} \
+ || die
+
+ emake || die "failed to compile xterm"
+
+ if use doc ; then
+ make ctlseqs.txt || die "failed to make documentation file"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README{,.i18n} ctlseqs.txt xterm.log.html
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" ${D}${DEFAULTS_DIR}/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/UXTerm
+}