summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-4.68-nolua.patch12
-rw-r--r--net-analyzer/nmap/nmap-4.68.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 4a78eee9eef5..f3898829838f 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.175 2008/07/02 20:45:50 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.176 2008/07/03 06:43:41 spock Exp $
+
+ 03 Jul 2008; Michał Januszewski <spock@gentoo.org>
+ files/nmap-4.68-nolua.patch, nmap-4.68.ebuild:
+ Really fix bug #230443.
02 Jul 2008; Michał Januszewski <spock@gentoo.org>
+files/nmap-4.68-nolua.patch, nmap-4.68.ebuild:
diff --git a/net-analyzer/nmap/files/nmap-4.68-nolua.patch b/net-analyzer/nmap/files/nmap-4.68-nolua.patch
index 1346ec94c6da..02d81069ff32 100644
--- a/net-analyzer/nmap/files/nmap-4.68-nolua.patch
+++ b/net-analyzer/nmap/files/nmap-4.68-nolua.patch
@@ -1,3 +1,15 @@
+diff -Naurp nmap-4.68-orig/configure.ac nmap-4.68/configure.ac
+--- nmap-4.68-orig/configure.ac 2008-07-02 22:37:00.000000000 +0200
++++ nmap-4.68/configure.ac 2008-07-03 08:23:54.000000000 +0200
+@@ -524,7 +524,7 @@ AC_HELP_STRING([--without-liblua], [Comp
+
+ # They don't want lua
+ if test "$no_lua" = "yes"; then
+- CXXFLAGS="-DNOLUA $CXXFLAGS"
++ CPPFLAGS="-DNOLUA $CPPFLAGS"
+ LIBLUA_LIBS=""
+ LUA_DEPENDS=""
+ LUA_BUILD=""
diff -Naurp nmap-4.68-orig/nmap.cc nmap-4.68/nmap.cc
--- nmap-4.68-orig/nmap.cc 2008-07-02 22:37:00.000000000 +0200
+++ nmap-4.68/nmap.cc 2008-07-02 22:37:20.000000000 +0200
diff --git a/net-analyzer/nmap/nmap-4.68.ebuild b/net-analyzer/nmap/nmap-4.68.ebuild
index 85894d6af9b6..5422f3e84006 100644
--- a/net-analyzer/nmap/nmap-4.68.ebuild
+++ b/net-analyzer/nmap/nmap-4.68.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.68.ebuild,v 1.2 2008/07/02 20:45:50 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.68.ebuild,v 1.3 2008/07/03 06:43:41 spock Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic autotools
DESCRIPTION="A utility for network exploration or security auditing"
HOMEPAGE="http://nmap.org/"
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-nolua.patch"
+ AT_NO_RECURSIVE=1 eautoreconf
}
pkg_setup() {