summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/acl/acl-20020330.ebuild43
-rw-r--r--sys-apps/acl/files/digest-acl-200203301
-rw-r--r--sys-apps/attr/attr-20020330.ebuild38
-rw-r--r--sys-apps/attr/files/digest-attr-200203301
-rw-r--r--sys-apps/dmapi/dmapi-20020330.ebuild35
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-200203301
-rw-r--r--sys-apps/xfsdump/files/digest-xfsdump-200203301
-rw-r--r--sys-apps/xfsdump/xfsdump-20020330.ebuild38
-rw-r--r--sys-apps/xfsprogs/files/digest-xfsprogs-200203301
-rw-r--r--sys-apps/xfsprogs/xfsprogs-20020330.ebuild31
10 files changed, 190 insertions, 0 deletions
diff --git a/sys-apps/acl/acl-20020330.ebuild b/sys-apps/acl/acl-20020330.ebuild
new file mode 100644
index 000000000000..a96c20ab9912
--- /dev/null
+++ b/sys-apps/acl/acl-20020330.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS dump/restore utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-apps/attr sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ include/builddefs.orig > include/builddefs || die
+# -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' \
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev install-lib || die
+ #fix freaky symlinks
+ cd ${D}/usr/lib
+ rm libacl.so
+ ln -s ../../lib/libacl.so libacl.so
+ cd ${D}/lib
+ rm *a
+ ln -s ../usr/lib/libacl.la libacl.la
+ ln -s ../usr/lib/libacl.a libacl.a
+}
diff --git a/sys-apps/acl/files/digest-acl-20020330 b/sys-apps/acl/files/digest-acl-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/attr/attr-20020330.ebuild b/sys-apps/attr/attr-20020330.ebuild
new file mode 100644
index 000000000000..08f3fa220e19
--- /dev/null
+++ b/sys-apps/attr/attr-20020330.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs extended attributes tools"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-lib install-dev || die
+ #dosym /usr/lib/libattr.a /lib/libattr.a
+ #dosym /usr/lib/libattr.la /lib/libattr.la
+ #dosym /lib/libattr.so /usr/lib/libattr.so
+}
diff --git a/sys-apps/attr/files/digest-attr-20020330 b/sys-apps/attr/files/digest-attr-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/dmapi/dmapi-20020330.ebuild b/sys-apps/dmapi/dmapi-20020330.ebuild
new file mode 100644
index 000000000000..1058e92d2163
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-20020330.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS data management API library"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/xfsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-20020330 b/sys-apps/dmapi/files/digest-dmapi-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/xfsdump/files/digest-xfsdump-20020330 b/sys-apps/xfsdump/files/digest-xfsdump-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/xfsdump/files/digest-xfsdump-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/xfsdump/xfsdump-20020330.ebuild b/sys-apps/xfsdump/xfsdump-20020330.ebuild
new file mode 100644
index 000000000000..9a935d660c05
--- /dev/null
+++ b/sys-apps/xfsdump/xfsdump-20020330.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/xfsdump-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs dump/restore utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs >=sys-apps/xfsprogs-${PV} >=sys-apps/dmapi-${PV} >=sys-apps/attr-${PV}"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ # 5) We now fix some absolute path symlinks in various makefiles
+ local x
+ for x in dump restore
+ do
+ cp ${x}/Makefile ${x}/Makefile.orig
+ sed -e 's:$(INSTALL) -S $(PKG_.*_DIR)/\(.*\) \(.*/.*\):$(INSTALL) -S ../../sbin/\1 \2:' ${x}/Makefile.orig > ${x}/Makefile
+ done
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/sys-apps/xfsprogs/files/digest-xfsprogs-20020330 b/sys-apps/xfsprogs/files/digest-xfsprogs-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/xfsprogs/files/digest-xfsprogs-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532
diff --git a/sys-apps/xfsprogs/xfsprogs-20020330.ebuild b/sys-apps/xfsprogs/xfsprogs-20020330.ebuild
new file mode 100644
index 000000000000..8b40d55825a1
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-20020330.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs filesystem utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e '/-S $(PKG/d' include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || die
+}