summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild6
-rw-r--r--sys-libs/db/db-4.0.14-r2.ebuild10
-rw-r--r--sys-libs/db/db-4.0.14-r3.ebuild12
-rw-r--r--sys-libs/db/db-4.1.25_p1-r3.ebuild12
-rw-r--r--sys-libs/db/db-4.1.25_p1-r4.ebuild12
-rw-r--r--sys-libs/db/db-4.1.25_p2.ebuild12
-rw-r--r--sys-libs/db/db-4.2.52_p2-r1.ebuild10
-rw-r--r--sys-libs/db/db-4.2.52_p2.ebuild10
-rw-r--r--sys-libs/db/db-4.2.52_p4-r2.ebuild12
-rw-r--r--sys-libs/db/db-4.2.52_p4.ebuild12
-rw-r--r--sys-libs/db/db-4.3.27.ebuild10
-rw-r--r--sys-libs/db/db-4.3.29-r2.ebuild12
-rw-r--r--sys-libs/db/db-4.3.29.ebuild12
-rw-r--r--sys-libs/db/db-4.4.20_p2.ebuild12
15 files changed, 86 insertions, 78 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 7760802023c6..c1edf4d185f6 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.165 2006/07/26 09:11:38 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.166 2006/08/03 23:46:04 cardoe Exp $
+
+ 03 Aug 2006; Doug Goldstein <cardoe@gentoo.org> db-3.2.9-r10.ebuild,
+ db-4.0.14-r2.ebuild, db-4.0.14-r3.ebuild, db-4.1.25_p1-r3.ebuild,
+ db-4.1.25_p1-r4.ebuild, db-4.1.25_p2.ebuild, db-4.2.52_p2.ebuild,
+ db-4.2.52_p2-r1.ebuild, db-4.2.52_p4.ebuild, db-4.2.52_p4-r2.ebuild,
+ db-4.3.27.ebuild, db-4.3.29.ebuild, db-4.3.29-r2.ebuild,
+ db-4.4.20_p2.ebuild:
+ Changed tcltk USE flag to tcl as per bug #17808
26 Jul 2006; Martin Schlemmer <azarah@gentoo.org> db-4.2.52_p4-r2.ebuild,
db-4.3.29-r2.ebuild:
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index dffc4b7aa46c..54a68e7d4841 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.23 2006/01/18 23:03:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.24 2006/08/03 23:46:04 cardoe Exp $
inherit gnuconfig libtool eutils db
@@ -84,8 +84,8 @@ src_compile() {
# TCL support is also broken
# Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
# conf_shared="${conf_shared}
- # `use_enable tcltk tcl`
- # `use_with tcltk tcl /usr/lib`"
+ # `use_enable tcl tcl`
+ # `use_with tcl tcl /usr/lib`"
# NOTE: we should not build both shared and static versions
# of the libraries in the same build root!
diff --git a/sys-libs/db/db-4.0.14-r2.ebuild b/sys-libs/db/db-4.0.14-r2.ebuild
index baa3b55b22d6..0845562c48bb 100644
--- a/sys-libs/db/db-4.0.14-r2.ebuild
+++ b/sys-libs/db/db-4.0.14-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.29 2005/07/10 20:59:39 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.30 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -8,12 +8,12 @@ S="${WORKDIR}/${P}/build_unix"
DESCRIPTION="Berkeley DB"
SRC_URI="ftp://ftp.sleepycat.com/releases/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
-IUSE="tcltk java doc"
+IUSE="tcl java doc"
SLOT="4"
LICENSE="DB"
KEYWORDS="x86 ppc sparc alpha mips hppa amd64 ia64"
-DEPEND="tcltk? ( dev-lang/tcl )
+DEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jdk )"
src_unpack() {
@@ -45,7 +45,7 @@ src_compile() {
&& myconf="${myconf} --enable-java" \
|| myconf="${myconf} --disable-java"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.0.14-r3.ebuild b/sys-libs/db/db-4.0.14-r3.ebuild
index dc39ab197268..47cd9c31e1dd 100644
--- a/sys-libs/db/db-4.0.14-r3.ebuild
+++ b/sys-libs/db/db-4.0.14-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r3.ebuild,v 1.16 2005/08/03 17:58:44 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r3.ebuild,v 1.17 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -8,15 +8,15 @@ S="${WORKDIR}/${P}/build_unix"
DESCRIPTION="Berkeley DB"
SRC_URI="ftp://ftp.sleepycat.com/releases/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
-IUSE="tcltk java doc"
+IUSE="tcl java doc"
SLOT="4"
LICENSE="DB"
KEYWORDS="alpha amd64 ~hppa ia64 m68k ~mips ppc ppc64 sparc x86"
-DEPEND="tcltk? ( dev-lang/tcl )
+DEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -50,7 +50,7 @@ src_compile() {
&& myconf="${myconf} --enable-java" \
|| myconf="${myconf} --disable-java"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.1.25_p1-r3.ebuild b/sys-libs/db/db-4.1.25_p1-r3.ebuild
index f339f4399ebd..2671464e75ea 100644
--- a/sys-libs/db/db-4.1.25_p1-r3.ebuild
+++ b/sys-libs/db/db-4.1.25_p1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r3.ebuild,v 1.32 2005/07/10 20:59:39 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r3.ebuild,v 1.33 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -28,12 +28,12 @@ done
LICENSE="DB"
SLOT="4.1"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 sh"
-IUSE="tcltk java doc"
+IUSE="tcl java doc"
-DEPEND="tcltk? ( dev-lang/tcl )
+DEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -62,7 +62,7 @@ src_compile() {
&& myconf="${myconf} --enable-java" \
|| myconf="${myconf} --disable-java"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.1.25_p1-r4.ebuild b/sys-libs/db/db-4.1.25_p1-r4.ebuild
index 4846a6db2d5a..0b9b9bc9b071 100644
--- a/sys-libs/db/db-4.1.25_p1-r4.ebuild
+++ b/sys-libs/db/db-4.1.25_p1-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r4.ebuild,v 1.22 2005/07/10 20:59:39 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r4.ebuild,v 1.23 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.1"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ~ppc ppc64 s390 sh sparc x86"
-IUSE="bootstrap doc java nocxx tcltk uclibc"
+IUSE="bootstrap doc java nocxx tcl uclibc"
-DEPEND="tcltk? ( dev-lang/tcl )
+DEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -61,7 +61,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.1.25_p2.ebuild b/sys-libs/db/db-4.1.25_p2.ebuild
index 5a4c565cd339..d9efd8d86781 100644
--- a/sys-libs/db/db-4.1.25_p2.ebuild
+++ b/sys-libs/db/db-4.1.25_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p2.ebuild,v 1.3 2006/05/20 13:12:45 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p2.ebuild,v 1.4 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="bootstrap doc java nocxx tcltk uclibc"
+IUSE="bootstrap doc java nocxx tcl uclibc"
-DEPEND="tcltk? ( dev-lang/tcl )
+DEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -61,7 +61,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -74,7 +74,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES; then
+ if use tcl && has test $FEATURES; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"
diff --git a/sys-libs/db/db-4.2.52_p2-r1.ebuild b/sys-libs/db/db-4.2.52_p2-r1.ebuild
index b601ef3c2fa3..faff559f3d91 100644
--- a/sys-libs/db/db-4.2.52_p2-r1.ebuild
+++ b/sys-libs/db/db-4.2.52_p2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p2-r1.ebuild,v 1.11 2006/05/30 19:57:27 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p2-r1.ebuild,v 1.12 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.2"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -62,7 +62,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.2.52_p2.ebuild b/sys-libs/db/db-4.2.52_p2.ebuild
index bd434f9e8857..2066fcd75970 100644
--- a/sys-libs/db/db-4.2.52_p2.ebuild
+++ b/sys-libs/db/db-4.2.52_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p2.ebuild,v 1.31 2006/05/30 19:57:27 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p2.ebuild,v 1.32 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.2"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -62,7 +62,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.2.52_p4-r2.ebuild b/sys-libs/db/db-4.2.52_p4-r2.ebuild
index 9c2d9e72a248..e13c61e81568 100644
--- a/sys-libs/db/db-4.2.52_p4-r2.ebuild
+++ b/sys-libs/db/db-4.2.52_p4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p4-r2.ebuild,v 1.2 2006/07/26 09:11:38 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p4-r2.ebuild,v 1.3 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db java-pkg-opt-2
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( >=virtual/jdk-1.4 )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( >=virtual/jre-1.4 )"
src_unpack() {
@@ -65,7 +65,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -80,7 +80,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES; then
+ if use tcl && has test $FEATURES; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"
diff --git a/sys-libs/db/db-4.2.52_p4.ebuild b/sys-libs/db/db-4.2.52_p4.ebuild
index 76e837c7b3b2..88526fe6e9d4 100644
--- a/sys-libs/db/db-4.2.52_p4.ebuild
+++ b/sys-libs/db/db-4.2.52_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p4.ebuild,v 1.5 2006/05/30 19:57:27 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p4.ebuild,v 1.6 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -62,7 +62,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -75,7 +75,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES; then
+ if use tcl && has test $FEATURES; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"
diff --git a/sys-libs/db/db-4.3.27.ebuild b/sys-libs/db/db-4.3.27.ebuild
index 04b11ad5c6c0..f2744ff52ece 100644
--- a/sys-libs/db/db-4.3.27.ebuild
+++ b/sys-libs/db/db-4.3.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.27.ebuild,v 1.6 2006/05/20 13:12:46 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.27.ebuild,v 1.7 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db
@@ -27,11 +27,11 @@ done
LICENSE="DB"
SLOT="4.3"
KEYWORDS="~amd64 ~ia64 ~m68k ~ppc ~sparc ~x86"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -62,7 +62,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
diff --git a/sys-libs/db/db-4.3.29-r2.ebuild b/sys-libs/db/db-4.3.29-r2.ebuild
index 76eaa44b2f1e..3648e255ef06 100644
--- a/sys-libs/db/db-4.3.29-r2.ebuild
+++ b/sys-libs/db/db-4.3.29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29-r2.ebuild,v 1.2 2006/07/26 09:11:38 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29-r2.ebuild,v 1.3 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db flag-o-matic java-pkg-opt-2
@@ -28,12 +28,12 @@ done
LICENSE="DB"
SLOT="4.3"
KEYWORDS="~amd64 ~ia64 ~m68k ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( >=virtual/jdk-1.4 )
>=sys-devel/binutils-2.16.1"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( >=virtual/jre-1.4 )"
src_unpack() {
@@ -67,7 +67,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -82,7 +82,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES ; then
+ if use tcl && has test $FEATURES ; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"
diff --git a/sys-libs/db/db-4.3.29.ebuild b/sys-libs/db/db-4.3.29.ebuild
index e954264ee3e3..bf591a022126 100644
--- a/sys-libs/db/db-4.3.29.ebuild
+++ b/sys-libs/db/db-4.3.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29.ebuild,v 1.7 2006/06/12 08:37:37 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29.ebuild,v 1.8 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db flag-o-matic
@@ -28,12 +28,12 @@ done
LICENSE="DB"
SLOT="4.3"
KEYWORDS="~amd64 ~ia64 ~m68k ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )
>=sys-devel/binutils-2.16.1"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -64,7 +64,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -77,7 +77,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES ; then
+ if use tcl && has test $FEATURES ; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"
diff --git a/sys-libs/db/db-4.4.20_p2.ebuild b/sys-libs/db/db-4.4.20_p2.ebuild
index 44d3389ed1f8..f6a65dbb3e2e 100644
--- a/sys-libs/db/db-4.4.20_p2.ebuild
+++ b/sys-libs/db/db-4.4.20_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.4.20_p2.ebuild,v 1.2 2006/05/20 14:40:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.4.20_p2.ebuild,v 1.3 2006/08/03 23:46:04 cardoe Exp $
inherit eutils gnuconfig db flag-o-matic
@@ -27,12 +27,12 @@ done
LICENSE="DB"
SLOT="4.4"
KEYWORDS="~amd64 ~ia64 ~m68k ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="tcltk java doc nocxx bootstrap"
+IUSE="tcl java doc nocxx bootstrap"
-DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
java? ( virtual/jdk )
>=sys-devel/binutils-2.16.1"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
java? ( virtual/jre )"
src_unpack() {
@@ -61,7 +61,7 @@ src_compile() {
&& myconf="${myconf} --disable-cxx" \
|| myconf="${myconf} $(use_enable !nocxx cxx)"
- use tcltk \
+ use tcl \
&& myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
@@ -74,7 +74,7 @@ src_compile() {
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
# the entire testsuite needs the TCL functionality
- if use tcltk && has test $FEATURES ; then
+ if use tcl && has test $FEATURES ; then
myconf="${myconf} --enable-test"
else
myconf="${myconf} --disable-test"