summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/cacti-0.8.7.ebuild95
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.73
-rw-r--r--net-analyzer/cacti/metadata.xml4
4 files changed, 105 insertions, 5 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index f32155f6a167..2b9b7bd461d2 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.111 2007/07/19 13:27:37 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.112 2007/10/29 15:03:46 jokey Exp $
+
+*cacti-0.8.7 (29 Oct 2007)
+
+ 29 Oct 2007; Markus Ullmann <jokey@gentoo.org> metadata.xml,
+ +cacti-0.8.7.ebuild:
+ Version bump with a bunch of fixes, check upstream changelog for details
19 Jul 2007; Christoph Mende <angelos@gentoo.org> cacti-0.8.6j-r6.ebuild:
Stable on amd64 wrt bug #172378
diff --git a/net-analyzer/cacti/cacti-0.8.7.ebuild b/net-analyzer/cacti/cacti-0.8.7.ebuild
new file mode 100644
index 000000000000..9a94664bda51
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7.ebuild,v 1.1 2007/10/29 15:03:46 jokey Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=0
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES="ping_php_version4_snmpgetnext
+ tree_console_missing_hosts
+ thumbnail_graphs_not_working
+ graph_debug_lockup_fix
+ snmpwalk_fix"
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp bundled-adodb"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+RDEPEND="!apache2? ( www-servers/lighttpd )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ !bundled-adodb? ( dev-php/adodb )
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+
+ use bundled-adodb || sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"/usr/share/php5/adodb/adodb.inc.php":' \
+ "${S}"/include/global.php
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ phpUseFlags="cli mysql xml session pcre"
+ elif [ $PHP_VERSION = 4 ] ; then
+ phpUseFlags="cli mysql xml session pcre expat"
+ fi
+ use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
+ require_php_with_use ${phpUseFlags}
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ use bundled-adodb || rm -rf lib/adodb
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.7 b/net-analyzer/cacti/files/digest-cacti-0.8.7
new file mode 100644
index 000000000000..a2fe27dc114b
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.7
@@ -0,0 +1,3 @@
+MD5 d28e8f9fd4b657c2ad79c4bcf1e3694d cacti-0.8.7.tar.gz 2405448
+RMD160 2d7b111fea85c59483621aa5c30056332976b05d cacti-0.8.7.tar.gz 2405448
+SHA256 6a30ef4588f27fd885389710003ead98a229c01d6b355dc958fc61be49eb3545 cacti-0.8.7.tar.gz 2405448
diff --git a/net-analyzer/cacti/metadata.xml b/net-analyzer/cacti/metadata.xml
index 5079e8cf393e..c13579549aea 100644
--- a/net-analyzer/cacti/metadata.xml
+++ b/net-analyzer/cacti/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>netmon</herd>
- <maintainer>
- <email>ramereth@gentoo.org</email>
- <name>Lance Albertson</name>
- </maintainer>
<longdescription lang="en">
Cacti is a complete network graphing solution designed to harness the
power of RRDTool's data storage and graphing functionality. Cacti