summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest14
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.81
-rw-r--r--sys-apps/sandbox/sandbox-1.2.8.ebuild98
4 files changed, 108 insertions, 12 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 4c3fab010854..6a746f151be2 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.15 2005/05/12 08:48:11 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.16 2005/05/13 15:50:15 azarah Exp $
+
+*sandbox-1.2.8 (13 May 2005)
+
+ 13 May 2005; Martin Schlemmer <azarah@gentoo.org> +sandbox-1.2.8.ebuild:
+ Cleanups and hopefully finally kill bug #91541. Fix bug #92478.
*sandbox-1.2.7 (12 May 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 3422e500b89d..e3ef8795fba7 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,7 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 974c54d97acb45fd30612e10fc9fe2bd ChangeLog 2520
+MD5 80025a2d36f44912359dd93cc31068d7 ChangeLog 2676
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 7ed1125d24e2a98b0832f84d9ab637da sandbox-1.2.4.ebuild 2145
MD5 2dbe688eca05e86a1b4679ede08c45cf sandbox-1.2.5.ebuild 2775
@@ -11,6 +8,7 @@ MD5 cf204fe7e04306977762e02426cd7469 sandbox-1.2.6.ebuild 2455
MD5 3c85f7c72e45afadde1025fc0ef3a205 sandbox-1.2.2.ebuild 2235
MD5 734eba450db4538f0e38ee876d28dacc sandbox-1.2.3.ebuild 2145
MD5 8adcaa7562849eea6c424d6fd10ee94c sandbox-1.2.7.ebuild 2517
+MD5 96b834ac8078a81c0e058da2998b955e sandbox-1.2.8.ebuild 2595
MD5 608cba289865ac916fb83ba5dc9daa2f files/digest-sandbox-1.2.4 66
MD5 54b60d2b6f5d3b74312b47c02e3f169e files/digest-sandbox-1.2.5 66
MD5 54b60d2b6f5d3b74312b47c02e3f169e files/digest-sandbox-1.2.5-r1 66
@@ -19,10 +17,4 @@ MD5 150aaffe0c9c0c8eb503c3f616d985f2 files/digest-sandbox-1.2.6 66
MD5 fb651b249c3214a6d0fa321e1d419e07 files/digest-sandbox-1.2.2 66
MD5 bf2c5f346fcc11659401c9240b1b8db9 files/digest-sandbox-1.2.3 66
MD5 ccaf432074b58217f8f1750228923978 files/digest-sandbox-1.2.7 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCgxmk1ZcsMnZjRyIRAi40AJ9OCK3zpaJSk+NleTSX0su8jfljPgCgoDWS
-+clOtxx+eGYuqpJ65G1DHH8=
-=PBOo
------END PGP SIGNATURE-----
+MD5 fcfb6124f08f3637efdf37a854b9f995 files/digest-sandbox-1.2.8 66
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.8 b/sys-apps/sandbox/files/digest-sandbox-1.2.8
new file mode 100644
index 000000000000..dedb30bd2a6b
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.8
@@ -0,0 +1 @@
+MD5 c21a2f44f7fe03efc4c3b903e4276e81 sandbox-1.2.8.tar.bz2 222948
diff --git a/sys-apps/sandbox/sandbox-1.2.8.ebuild b/sys-apps/sandbox/sandbox-1.2.8.ebuild
new file mode 100644
index 000000000000..d7a6411b45bb
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.8.ebuild,v 1.1 2005/05/13 15:50:15 azarah Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+DEPEND="virtual/libc"
+
+setup_multilib() {
+ if use amd64 && has_m32 && [[ ${CONF_MULTILIBDIR} == "lib32" ]]; then
+ export DEFAULT_ABI="amd64"
+ export MULTILIB_ABIS="x86 amd64"
+ export CFLAGS_amd64=${CFLAGS_amd64:-"-m64"}
+ export CFLAGS_x86=${CFLAGS_x86-"-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"}
+ export LIBDIR_amd64=${LIBDIR_amd64-${CONF_LIBDIR}}
+ export LIBDIR_x86=${LIBDIR_x86-${CONF_MULTILIBDIR}}
+ fi
+}
+
+src_unpack() {
+ setup_multilib
+ for ABI in $(get_install_abis) ; do
+ unpack ${A}
+ cd ${WORKDIR}
+ einfo "Unpacking sandbox for ABI=${ABI}..."
+ mv ${S} ${S%/}-${ABI} || die "failed moving \$S to ${ABI}"
+ done
+}
+
+abi_fail_check() {
+ local ABI=$1
+ if [[ ${ABI} == "x86" ]] ; then
+ echo
+ eerror "Building failed for ABI=x86!. This usually means a broken"
+ eerror "multilib setup. Please fix that before filling a bugreport"
+ eerror "against sandbox."
+ echo
+ fi
+}
+
+src_compile() {
+ setup_multilib
+
+ filter-lfs-flags #90228
+
+ has_multilib_profile && append-flags -DSB_HAVE_64BIT_ARCH
+
+ ewarn "If configure fails with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ econf --libdir="/usr/$(get_libdir)"
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || {
+ abi_fail_check "${ABI}"
+ die "emake failed for ${ABI}"
+ }
+ done
+ ABI="${OABI}"
+}
+
+src_install() {
+ setup_multilib
+
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einfo "Installing sandbox for ABI=${ABI}..."
+ make DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI="${OABI}"
+
+ for x in "${S}-${ABI}"/{AUTHORS,COPYING,ChangeLog,NEWS,README} ; do
+ [[ -f ${x} && $(stat -c "%s" "${x}") -gt 0 ]] && dodoc "${x}"
+ done
+}