summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/lvm2/ChangeLog42
-rw-r--r--sys-apps/lvm2/files/digest-lvm2-2.00.051
-rw-r--r--sys-apps/lvm2/lvm2-2.00.05.ebuild29
-rw-r--r--sys-libs/device-mapper/ChangeLog26
-rw-r--r--sys-libs/device-mapper/device-mapper-1.00.05.ebuild39
-rw-r--r--sys-libs/device-mapper/files/digest-device-mapper-1.00.051
6 files changed, 138 insertions, 0 deletions
diff --git a/sys-apps/lvm2/ChangeLog b/sys-apps/lvm2/ChangeLog
new file mode 100644
index 000000000000..7d33b5bc5fb0
--- /dev/null
+++ b/sys-apps/lvm2/ChangeLog
@@ -0,0 +1,42 @@
+# ChangeLog for sys-apps/lvm2
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm2/ChangeLog,v 1.1 2003/09/02 20:47:37 max Exp $
+
+*lvm2-2.00.05 (02 Sep 2003)
+
+ 02 Sep 2003; Max Kalika <max@gentoo.org> lvm2-2.00.05.ebuild:
+ Bump version to 2.00.05.
+
+ 03 Jul 2003; Max Kalika <max@gentoo.org> lvm2-1.95.15.ebuild:
+ Set KEYWORDS to ~x86.
+
+ 12 Jun 2003; Max Kalika <max@gentoo.org> lvm2-1.95.15.ebuild:
+ Drop unneccessary die() calls.
+
+ 29 May 2003; Max Kalika <max@gentoo.org> lvm2-1.95.10.ebuild,
+ lvm2-1.95.15.ebuild, files/lvm2.rc6:
+ Remove stale version. Patch /etc/init.d/{checkfs,halt.sh} to
+ activate/deactivate LVM2. Remove the no longer needed lvm2.rc6 file.
+
+*lvm2-1.95.15 (27 May 2003)
+
+ 27 May 2003; Max Kalika <max@gentoo.org> lvm2-1.95.15.ebuild:
+ Bump version.
+
+ 22 May 2003; root <root> lvm2-1.95.10.ebuild, files/lvm2.rc6:
+ Install binary and all symlinks to /sbin as well. Fixes booting if /usr
+ is a separate partition. Change startup script to look for utilities in
+ /sbin. Fix startup script modules depend.
+
+ 15 May 2003; Max Kalika <max@gentoo.org> files/lvm2.rc6:
+ Start before checkfs.
+
+ 14 May 2003; Max Kalika <max@gentoo.org> lvm2-1.95.10.ebuild,
+ files/lvm2.rc6:
+ Add startup script.
+
+*lvm2-1.95.10 (12 May 2003)
+
+ 12 May 2003; Max Kalika <max@gentoo.org> lvm2-1.95.10.ebuild:
+ Initial version.
+
diff --git a/sys-apps/lvm2/files/digest-lvm2-2.00.05 b/sys-apps/lvm2/files/digest-lvm2-2.00.05
new file mode 100644
index 000000000000..8995267fa741
--- /dev/null
+++ b/sys-apps/lvm2/files/digest-lvm2-2.00.05
@@ -0,0 +1 @@
+MD5 e36dd7dc97b157dfb406ebf9598e3ce7 LVM2.2.00.05.tgz 266009
diff --git a/sys-apps/lvm2/lvm2-2.00.05.ebuild b/sys-apps/lvm2/lvm2-2.00.05.ebuild
new file mode 100644
index 000000000000..978c30e517a5
--- /dev/null
+++ b/sys-apps/lvm2/lvm2-2.00.05.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm2/lvm2-2.00.05.ebuild,v 1.1 2003/09/02 20:47:37 max Exp $
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://www.sistina.com/products_lvm.htm"
+SRC_URI="ftp://ftp.sistina.com/pub/LVM2/tools/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/device-mapper-1"
+RDEPEND="${DEPEND}
+ !sys-apps/lvm-user"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_compile() {
+ econf
+
+ # Parallel build doesn't work.
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin"
+ dodoc BUGS COPYING* INSTALL INTRO README TODO VERSION doc/*
+}
diff --git a/sys-libs/device-mapper/ChangeLog b/sys-libs/device-mapper/ChangeLog
new file mode 100644
index 000000000000..42fe4d340b3b
--- /dev/null
+++ b/sys-libs/device-mapper/ChangeLog
@@ -0,0 +1,26 @@
+# ChangeLog for sys-libs/device-mapper
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/device-mapper/ChangeLog,v 1.1 2003/09/02 20:45:55 max Exp $
+
+*device-mapper-1.00.05 (02 Sep 2003)
+
+ 02 Sep 2003; Max Kalika <max@gentoo.org> device-mapper-1.00.05.ebuild:
+ Bump version to 1.00.05.
+
+ 03 Jul 2003; Max Kalika <max@gentoo.org> device-mapper-0.96.08.ebuild:
+ Set KEYWORDS to ~x86.
+
+ 12 Jun 2003; Max Kalika <max@gentoo.org> device-mapper-0.96.08.ebuild:
+ Drop unneccessary die() calls.
+
+ 29 May 2003; Max Kalika <max@gentoo.org> device-mapper-0.96.08.ebuild:
+ Better kernel-support error message.
+
+ 23 May 2003; Max Kalika <max@gentoo.org> device-mapper-0.96.08.ebuild:
+ Install libdevmapper.so to /lib as well.
+
+*device-mapper-0.96.08 (12 May 2003)
+
+ 12 May 2003; Max Kalika <max@gentoo.org> device-mapper-0.96.08.ebuild:
+ Initial version.
+
diff --git a/sys-libs/device-mapper/device-mapper-1.00.05.ebuild b/sys-libs/device-mapper/device-mapper-1.00.05.ebuild
new file mode 100644
index 000000000000..337a5cf735b4
--- /dev/null
+++ b/sys-libs/device-mapper/device-mapper-1.00.05.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/device-mapper/device-mapper-1.00.05.ebuild,v 1.1 2003/09/02 20:45:55 max Exp $
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities."
+HOMEPAGE="http://www.sistina.com/products_lvm.htm"
+SRC_URI="ftp://ftp.sistina.com/pub/LVM2/${PN}/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/linux-sources"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_unpack() {
+ [ ! -e "/usr/src/linux/include/linux/dm-ioctl.h" ] && {
+ eerror
+ eerror "Your currently linked kernel (/usr/src/linux) hasn't"
+ eerror "been patched for device mapper support."
+ eerror
+ die "kernel not patched for device mapper support"
+ }
+
+ unpack ${A}
+}
+
+src_compile() {
+ econf
+
+ # parallel build doesn't work
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" libdir="${D}/lib"
+ dodoc COPYING* INSTALL INTRO README VERSION
+}
diff --git a/sys-libs/device-mapper/files/digest-device-mapper-1.00.05 b/sys-libs/device-mapper/files/digest-device-mapper-1.00.05
new file mode 100644
index 000000000000..eae71832acf1
--- /dev/null
+++ b/sys-libs/device-mapper/files/digest-device-mapper-1.00.05
@@ -0,0 +1 @@
+MD5 f8203b25454dcef90f37b3bdf42d8817 device-mapper.1.00.05.tgz 373605