summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/daapd/ChangeLog10
-rw-r--r--media-sound/daapd/Manifest11
-rw-r--r--media-sound/daapd/daapd-0.2.3b.ebuild59
-rw-r--r--media-sound/daapd/files/daapd-0.2.3b-gentoo.patch43
-rw-r--r--media-sound/daapd/files/daapd-0.2.3b-mpeg4.patch12
-rw-r--r--media-sound/daapd/files/digest-daapd-0.2.3b1
6 files changed, 132 insertions, 4 deletions
diff --git a/media-sound/daapd/ChangeLog b/media-sound/daapd/ChangeLog
index 52dc90bbcb8a..aa7180992a26 100644
--- a/media-sound/daapd/ChangeLog
+++ b/media-sound/daapd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/daapd
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/ChangeLog,v 1.3 2004/06/24 23:56:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/ChangeLog,v 1.4 2004/08/18 21:16:43 eradicator Exp $
+
+*daapd-0.2.3b (18 Aug 2004)
+
+ 18 Aug 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/daapd-0.2.3b-gentoo.patch, +files/daapd-0.2.3b-mpeg4.patch,
+ +daapd-0.2.3b.ebuild:
+ Initial commit of version bump in -* because of compilation problems. See bug
+ #49422.
*daapd-0.2.1d (30 Mar 2004)
diff --git a/media-sound/daapd/Manifest b/media-sound/daapd/Manifest
index 1c6acc95814f..1e94ce1c12d3 100644
--- a/media-sound/daapd/Manifest
+++ b/media-sound/daapd/Manifest
@@ -1,8 +1,13 @@
-MD5 a536a4ad7975642df2a610dc11163dde daapd-0.2.1d.ebuild 1277
MD5 842adee9018c9c6c3a377284234e7ffe ChangeLog 967
+MD5 a536a4ad7975642df2a610dc11163dde daapd-0.2.1d.ebuild 1277
MD5 67fa7232a65762eb47d8773c5fb33811 metadata.xml 592
+MD5 6d80c14e8c26c5034182b94d4030dd4a daapd-0.2.3b.ebuild 1436
+MD5 6a94f39460d57008cfec35d65b784951 files/0.2.1d-makefile-gentoo.patch 343
+MD5 71d5acf0144c38a510d37e388e6f4b4d files/0.2.1d-zeroconf-gentoo.patch 5182
MD5 3beda326653c14c1fbd33c762af01e2e files/daapd.conf.d 673
MD5 c9efc1a26641469dad49ba6fade5f8b9 files/daapd.init.d 1046
-MD5 71d5acf0144c38a510d37e388e6f4b4d files/0.2.1d-zeroconf-gentoo.patch 5182
-MD5 6a94f39460d57008cfec35d65b784951 files/0.2.1d-makefile-gentoo.patch 343
MD5 d288598cd3334e91bb0822932d8cdd96 files/digest-daapd-0.2.1d 60
+MD5 0b165022611e3da42035fa582e78b075 files/daapd-0.2.3b-gentoo.patch 1584
+MD5 ab75a66a1f905fc7b49012c87d63421d files/daapd-0.2.3b-mpeg4.patch 333
+MD5 8e45b744d7830e3e53e207ded8ef84f8 files/digest-daapd-0.2.3b 61
+MD5 616423cb81ee70fd7da98acc30bd7650 files/daapd-0.2.3b-extlibs-gentoo.patch 480
diff --git a/media-sound/daapd/daapd-0.2.3b.ebuild b/media-sound/daapd/daapd-0.2.3b.ebuild
new file mode 100644
index 000000000000..d9284c4031e6
--- /dev/null
+++ b/media-sound/daapd/daapd-0.2.3b.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/daapd/daapd-0.2.3b.ebuild,v 1.1 2004/08/18 21:16:43 eradicator Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="daapd scans a directory for mp3 files and makes them available via the Apple proprietary protocol DAAP"
+HOMEPAGE="http://www.deleet.de/projekte/daap/daapd/"
+SRC_URI="http://www.deleet.de/projekte/daap/daapd/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~x86 ~amd64"
+KEYWORDS="-*"
+IUSE="mpeg4"
+DEPEND="sys-libs/zlib
+ >=net-misc/howl-0.9.5
+ >=media-libs/libid3tag-0.15.0b
+ mpeg4? media-libs/faad2
+ >=net-libs/libhttpd-persistent-1.3p-r8
+ >=media-libs/daaplib-0.1.1a"
+
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ if use mpeg4; then
+ epatch ${FILESDIR}/${P}-mpeg4.patch
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+
+# emake DESTDIR=${D} DEPLOY=${D}usr install || die "emake install failed"
+
+ dobin daapd
+# dolib daaplib/src/libdaaplib.a
+# dolib libhttpd/src/libhttpd-persistent.a
+
+ dodoc COPYING README* daapd-example.conf
+ doman ${PN}.8
+
+# insinto /usr/include
+# doins libhttpd/src/httpd-persistent.h
+
+ insinto /etc
+ newins daapd-example.conf daapd.conf
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/daapd.conf.d daapd || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/daapd.init.d daapd || die
+}
+
diff --git a/media-sound/daapd/files/daapd-0.2.3b-gentoo.patch b/media-sound/daapd/files/daapd-0.2.3b-gentoo.patch
new file mode 100644
index 000000000000..5da7cb36dbfd
--- /dev/null
+++ b/media-sound/daapd/files/daapd-0.2.3b-gentoo.patch
@@ -0,0 +1,43 @@
+diff -urN daapd-0.2.3b/makefile daapd-0.2.3b.makefile/makefile
+--- daapd-0.2.3b/makefile 2004-06-20 16:07:31.000000000 +0200
++++ daapd-0.2.3b.makefile/makefile 2004-07-10 22:18:15.694502696 +0200
+@@ -11,19 +11,19 @@
+ CC = g++
+ MAKE = $(MAKE_COMMAND)
+ TARGET = daapd
+-DEPS = daaplib_ libhttpd_
++DEPS =
+ OBJS = daapd.o db.o dboutput.o songcache.o parsemp3.o
+ LIBS = -ldaaplib -lhttpd-persistent -lid3tag -lz -lpthread
+-LIBPATH = -L. -L./daaplib/src -L./libhttpd/src -L/usr/local/lib
+-INCPATH = -I. -I./daaplib/include -I./libhttpd/src -I/usr/local/include
+-DEPLOY = /usr/local
++LIBPATH = -L. -L/usr/lib
++INCPATH = -I. -I/usr/include
++DEPLOY = /usr
+ CFLAGS = -Wall -Wno-multichar
+
+ # HOWL
+ ifeq ($(HOWL_ENABLE),1)
+- HOWLDIRS := $(sort $(wildcard /usr/local/include/howl*) )
++ HOWLDIRS := $(sort $(wildcard /usr/include/howl*) )
+ ifeq ($(words $(HOWLDIRS) ), 0)
+-$(error howl not found in /usr/local/include. Install howl or disable it in the makefile)
++$(error howl not found in /usr/include. Install howl or disable it in the makefile)
+ endif
+ HOWLRECENT := $(word $(words $(HOWLDIRS)),$(HOWLDIRS) )
+ INCPATH := $(INCPATH) -I$(HOWLRECENT)
+diff -urN daapd-0.2.3b/types.h daapd-0.2.3b.types.h/types.h
+--- daapd-0.2.3b/types.h 2004-06-19 17:40:04.000000000 +0200
++++ daapd-0.2.3b.types.h/types.h 2004-07-10 22:32:53.584043200 +0200
+@@ -20,6 +20,10 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#ifndef UINT64_TO_DOUBLE
++#define UINT64_TO_DOUBLE(a) ((double)((int64_t)(a)))
++#endif
++
+ #ifndef DAAP_TYPES_H
+ #define DAAP_TYPES_H
+
diff --git a/media-sound/daapd/files/daapd-0.2.3b-mpeg4.patch b/media-sound/daapd/files/daapd-0.2.3b-mpeg4.patch
new file mode 100644
index 000000000000..1e2b06615df7
--- /dev/null
+++ b/media-sound/daapd/files/daapd-0.2.3b-mpeg4.patch
@@ -0,0 +1,12 @@
+diff -urN daapd-0.2.3b/makefile daapd-0.2.3b.makefile/makefile
+--- daapd-0.2.3b/makefile 2004-07-10 22:10:51.784987200 +0200
++++ daapd-0.2.3b.makefile/makefile 2004-07-10 22:13:10.216942344 +0200
+@@ -2,7 +2,7 @@
+
+ HOWL_ENABLE = 1
+ ZLIB_ENABLE = 1
+-MPEG4_ENABLE = 0
++MPEG4_ENABLE = 1
+
+
+ # no need to touch anything below this line
diff --git a/media-sound/daapd/files/digest-daapd-0.2.3b b/media-sound/daapd/files/digest-daapd-0.2.3b
new file mode 100644
index 000000000000..e5dfc2815029
--- /dev/null
+++ b/media-sound/daapd/files/digest-daapd-0.2.3b
@@ -0,0 +1 @@
+MD5 19e9dd184e01ac5b035f48f58daa5f06 daapd-0.2.3b.tgz 201985