summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/matplotlib/ChangeLog5
-rw-r--r--dev-python/matplotlib/matplotlib-9999.ebuild32
2 files changed, 25 insertions, 12 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 6055b9e38159..41639221ed8d 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.163 2013/12/26 18:55:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.164 2013/12/26 19:01:54 jlec Exp $
+
+ 26 Dec 2013; Justin Lecher <jlec@gentoo.org> matplotlib-9999.ebuild:
+ Propagate changes into live ebuild
26 Dec 2013; Justin Lecher <jlec@gentoo.org> matplotlib-1.3.1.ebuild:
Update deps for USE=pyside and fix sandbox problems for gtk+3
diff --git a/dev-python/matplotlib/matplotlib-9999.ebuild b/dev-python/matplotlib/matplotlib-9999.ebuild
index 6fbe17c000bc..7a41b2e8b91f 100644
--- a/dev-python/matplotlib/matplotlib-9999.ebuild
+++ b/dev-python/matplotlib/matplotlib-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.1 2013/12/12 14:30:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.2 2013/12/26 19:01:54 jlec Exp $
EAPI=5
@@ -8,6 +8,8 @@ PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
PYTHON_REQ_USE='tk?'
+VIRTUALX_REQUIRED="always"
+
inherit distutils-r1 eutils flag-o-matic git-r3 virtualx
DESCRIPTION="Pure python plotting library with matlab like syntax"
@@ -75,7 +77,7 @@ RDEPEND="${COMMON_DEPEND}
dev-texlive/texlive-latexextra
dev-texlive/texlive-xetex
)
- pyside? ( dev-python/pyside[X,${PY2_USEDEP},${PY32_USEDEP}] )
+ pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
@@ -85,7 +87,6 @@ REQUIRED_USE="
excel? ( ${PY2_FLAGS} )
fltk? ( ${PY2_FLAGS} )
gtk? ( ${PY2_FLAGS} )
- pyside? ( ${PY2_FLAGS} ${PY32_FLAGS} )
wxwidgets? ( ${PY2_FLAGS} )
test? (
cairo fltk latex pyside qt4 tk wxwidgets
@@ -110,6 +111,13 @@ use_setup() {
}
python_prepare_all() {
+# Generates test failures, but fedora does it
+# local PATCHES=(
+# "${FILESDIR}"/${P}-unbundle-pycxx.patch
+# "${FILESDIR}"/${P}-unbundle-agg.patch
+# )
+# rm -r agg24 CXX || die
+# rm -r agg24 || die
sed \
-e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
-i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
@@ -120,6 +128,11 @@ python_prepare_all() {
-e '/tol/s:32:35:g' \
-i lib/matplotlib/tests/test_mathtext.py || die
+ if use gtk || use gtk3; then
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+ fi
distutils-r1_python_prepare_all
}
@@ -183,8 +196,8 @@ wrap_setup() {
}
python_compile() {
- VIRTUALX_COMMAND="wrap_setup"
- virtualmake distutils-r1_python_compile
+ VIRTUALX_COMMAND="wrap_setup distutils-r1_python_compile"
+ virtualmake
}
python_compile_all() {
@@ -201,15 +214,12 @@ python_compile_all() {
}
python_test() {
- VIRTUALX_COMMAND="wrap_setup"
- virtualmake distutils_install_for_testing
+ wrap_setup distutils_install_for_testing
cd "${TMPDIR}" || die
VIRTUALX_COMMAND="${PYTHON}"
- virtualmake -c "
-import sys, matplotlib as m
-sys.exit(0 if m.test(verbosity=2) else 1)
-" || die "Tests fail with ${EPYTHON}"
+ virtualmake -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || \
+ die "Tests fail with ${EPYTHON}"
}
python_install() {