summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/privoxy/ChangeLog8
-rw-r--r--net-proxy/privoxy/files/privoxy-3.0.11-timeout.patch20
-rw-r--r--net-proxy/privoxy/privoxy-3.0.11-r1.ebuild64
3 files changed, 91 insertions, 1 deletions
diff --git a/net-proxy/privoxy/ChangeLog b/net-proxy/privoxy/ChangeLog
index cd5870db4722..40592d125ffd 100644
--- a/net-proxy/privoxy/ChangeLog
+++ b/net-proxy/privoxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/privoxy
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/ChangeLog,v 1.45 2009/03/13 20:00:28 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/ChangeLog,v 1.46 2009/03/22 10:55:14 mrness Exp $
+
+*privoxy-3.0.11-r1 (22 Mar 2009)
+
+ 22 Mar 2009; Alin Năstac <mrness@gentoo.org>
+ +files/privoxy-3.0.11-timeout.patch, +privoxy-3.0.11-r1.ebuild:
+ Import upstream fix for a bug regarding timeout handling (#262820).
*privoxy-3.0.11 (13 Mar 2009)
diff --git a/net-proxy/privoxy/files/privoxy-3.0.11-timeout.patch b/net-proxy/privoxy/files/privoxy-3.0.11-timeout.patch
new file mode 100644
index 000000000000..0433e1d923ec
--- /dev/null
+++ b/net-proxy/privoxy/files/privoxy-3.0.11-timeout.patch
@@ -0,0 +1,20 @@
+--- jcc.c 2009/03/08 14:19:23 1.231
++++ jcc.c 2009/03/08 19:29:16 1.232
+@@ -2600,8 +2605,6 @@
+ struct timeval timeout;
+
+ memset(buf, 0, sizeof(buf));
+- memset(&timeout, 0, sizeof(timeout));
+- timeout.tv_sec = csp->config->socket_timeout;
+
+ http = csp->http;
+
+@@ -2843,6 +2846,8 @@
+ }
+ #endif /* FEATURE_CONNECTION_KEEP_ALIVE */
+
++ timeout.tv_sec = csp->config->socket_timeout;
++ timeout.tv_usec = 0;
+ n = select((int)maxfd+1, &rfds, NULL, NULL, &timeout);
+
+ if (n == 0)
diff --git a/net-proxy/privoxy/privoxy-3.0.11-r1.ebuild b/net-proxy/privoxy/privoxy-3.0.11-r1.ebuild
new file mode 100644
index 000000000000..95bdc22bbf78
--- /dev/null
+++ b/net-proxy/privoxy/privoxy-3.0.11-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/privoxy-3.0.11-r1.ebuild,v 1.1 2009/03/22 10:55:14 mrness Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs autotools
+
+HOMEPAGE="http://www.privoxy.org
+ http://sourceforge.net/projects/ijbswa/"
+DESCRIPTION="A web proxy with advanced filtering capabilities for protecting privacy against Internet junk"
+SRC_URI="mirror://sourceforge/ijbswa/${P/_/-}-stable-src.tar.gz"
+
+IUSE="selinux threads zlib"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/libpcre
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-privoxy )"
+
+S="${WORKDIR}/${P/_/-}-stable"
+
+pkg_setup() {
+ enewgroup privoxy
+ enewuser privoxy -1 -1 /etc/privoxy privoxy
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-timeout.patch # should be fixed in versions >= 3.0.12
+ # autoreconf needs to be called even if we don't modify any autotools source files
+ # See main makefile
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ export CC=$(tc-getCC)
+ econf \
+ $(use_enable zlib) \
+ $(use_enable threads pthread) \
+ --enable-dynamic-pcre \
+ --with-user=privoxy \
+ --with-group=privoxy \
+ --sysconfdir=/etc/privoxy \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/privoxy.initd" privoxy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/privoxy.logrotate" privoxy
+
+ diropts -m 0750 -g privoxy -o privoxy
+ keepdir /var/log/privoxy
+}