summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/libtool/ChangeLog7
-rw-r--r--sys-devel/libtool/libtool-1.4.3-r3.ebuild14
-rw-r--r--sys-devel/libtool/libtool-1.4.3-r4.ebuild14
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r3.ebuild17
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r4.ebuild17
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r5.ebuild14
-rw-r--r--sys-devel/libtool/libtool-1.5.6.ebuild22
7 files changed, 36 insertions, 69 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index e24ca0efc49f..7f694522d00e 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.50 2004/07/15 21:22:38 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.51 2004/07/16 04:03:19 agriffis Exp $
+
+ 15 Jul 2004; Aron Griffis <agriffis@gentoo.org> libtool-1.4.3-r3.ebuild,
+ libtool-1.4.3-r4.ebuild, libtool-1.5.2-r3.ebuild, libtool-1.5.2-r4.ebuild,
+ libtool-1.5.2-r5.ebuild, libtool-1.5.6.ebuild:
+ Fix all the gnuconfig_update screwiness in these ebuilds #57224
15 Jul 2004; Tom Gall <tgall@gentoo.org> libtool-1.5.2-r5.ebuild:
calling multiple gnuconfig_updates in a row kills gnus
diff --git a/sys-devel/libtool/libtool-1.4.3-r3.ebuild b/sys-devel/libtool/libtool-1.4.3-r3.ebuild
index 313a4cbb7af1..39e1cb8a0484 100644
--- a/sys-devel/libtool/libtool-1.4.3-r3.ebuild
+++ b/sys-devel/libtool/libtool-1.4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r3.ebuild,v 1.9 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r3.ebuild,v 1.10 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -66,8 +66,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-mktemp.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -115,6 +113,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -126,9 +128,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -143,9 +142,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/sys-devel/libtool/libtool-1.4.3-r4.ebuild b/sys-devel/libtool/libtool-1.4.3-r4.ebuild
index db9bc7ef629f..d60ee80a6e02 100644
--- a/sys-devel/libtool/libtool-1.4.3-r4.ebuild
+++ b/sys-devel/libtool/libtool-1.4.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r4.ebuild,v 1.6 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r4.ebuild,v 1.7 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
inherit eutils gnuconfig
@@ -65,8 +65,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -118,6 +116,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -129,9 +131,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64 and uclibc
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -146,9 +145,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64 and uclibc
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/sys-devel/libtool/libtool-1.5.2-r3.ebuild b/sys-devel/libtool/libtool-1.5.2-r3.ebuild
index eab7fa59e625..d2b59ddd528b 100644
--- a/sys-devel/libtool/libtool-1.5.2-r3.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r3.ebuild,v 1.6 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r3.ebuild,v 1.7 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -66,8 +66,6 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -128,6 +126,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -139,12 +141,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64
- gnuconfig_update
-
- # regen to allow for build,host,target ppc64
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -159,9 +155,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/sys-devel/libtool/libtool-1.5.2-r4.ebuild b/sys-devel/libtool/libtool-1.5.2-r4.ebuild
index 68c498472471..e285ef8419da 100644
--- a/sys-devel/libtool/libtool-1.5.2-r4.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r4.ebuild,v 1.4 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r4.ebuild,v 1.5 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -66,8 +66,6 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -129,6 +127,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -140,12 +142,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64
- gnuconfig_update
-
- # regen to allow for build,host,target ppc64
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -160,9 +156,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/sys-devel/libtool/libtool-1.5.2-r5.ebuild b/sys-devel/libtool/libtool-1.5.2-r5.ebuild
index d95bd19cc9a0..a4b68ea47776 100644
--- a/sys-devel/libtool/libtool-1.5.2-r5.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r5.ebuild,v 1.15 2004/07/15 21:22:38 tgall Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r5.ebuild,v 1.16 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig
@@ -68,8 +68,6 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- S="${OLD_S}" gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -131,6 +129,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -142,9 +144,6 @@ src_compile() {
cd ${OLD_S}
- # regen to allow for build,host,target mips/mips64/ppc64/uclibc
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -159,9 +158,6 @@ src_compile() {
cd ${S}
- # regen to allow for build,host,target mips/mips64/ppc64/uclibc
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/sys-devel/libtool/libtool-1.5.6.ebuild b/sys-devel/libtool/libtool-1.5.6.ebuild
index 99e82684f6eb..7374538876d3 100644
--- a/sys-devel/libtool/libtool-1.5.6.ebuild
+++ b/sys-devel/libtool/libtool-1.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.4 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.5 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig
@@ -70,8 +70,6 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -133,6 +131,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -144,15 +146,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64
- gnuconfig_update
-
- # regen to allow for build,host,target ppc64
- gnuconfig_update
-
- # detect uclibc
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -167,11 +160,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64
- gnuconfig_update
-
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \