summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/heretic2/ChangeLog10
-rw-r--r--games-action/heretic2/heretic2-1.06c-r1.ebuild95
2 files changed, 102 insertions, 3 deletions
diff --git a/games-action/heretic2/ChangeLog b/games-action/heretic2/ChangeLog
index 9b508cd0efba..31982a5866ee 100644
--- a/games-action/heretic2/ChangeLog
+++ b/games-action/heretic2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/heretic2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.11 2012/02/05 05:00:48 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.12 2014/06/25 13:01:57 mgorny Exp $
+
+*heretic2-1.06c-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> +heretic2-1.06c-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
05 Feb 2012; Mike Frysinger <vapier@gentoo.org> heretic2-1.06c.ebuild:
Move to new unpacker eclass for unpack_makeself.
@@ -39,4 +44,3 @@
03 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +metadata.xml,
+heretic2-1.06c.ebuild:
Initial commit. Modified ebuild from bug #136869 by Anton Romanov.
-
diff --git a/games-action/heretic2/heretic2-1.06c-r1.ebuild b/games-action/heretic2/heretic2-1.06c-r1.ebuild
new file mode 100644
index 000000000000..f9524d77f953
--- /dev/null
+++ b/games-action/heretic2/heretic2-1.06c-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c-r1.ebuild,v 1.1 2014/06/25 13:01:57 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker cdrom multilib games
+
+DESCRIPTION="Third-person classic magical action-adventure game"
+HOMEPAGE="http://lokigames.com/products/heretic2/
+ http://www.ravensoft.com/heretic2.html"
+SRC_URI="mirror://lokigames/${PN}/${P/%?/b}-unified-x86.run
+ mirror://lokigames/${PN}/${P}-unified-x86.run
+ mirror://lokigames/${PN}/${PN}-maps-1.0.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/${PN}/base/*.so"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="virtual/opengl
+ amd64? (
+ || (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ || (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ )
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds bin/x86/glibc-2.1/${PN}
+ mkdir ${A}
+
+ local f
+ for f in * ; do
+ cd "${S}"/${f}
+ unpack_makeself ${f}
+ done
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ cd "${CDROM_ROOT}"
+
+ insinto "${dir}"
+ doins -r base help Manual.html README README.more
+
+ exeinto "${dir}"
+ doexe bin/x86/glibc-2.1/${PN}
+
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ sed -i \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${D}/${GAMES_BINDIR}/${PN}" || die
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Heretic II"
+
+ cd "${D}/${dir}"
+ ln -s "${CDROM_ROOT}"/*.gz .
+ unpack ./*.gz
+ rm -f *.gz
+
+ local d
+ for d in "${S}"/* ; do
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ popd > /dev/null
+ done
+
+ rmdir gl_drivers
+ sed -i \
+ "128i set gl_driver \"/usr/$(get_libdir)/libGL.so\"" \
+ base/default.cfg \
+ || die "sed failed"
+
+ prepgamesdirs
+}