summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-misc/sdljoytest/ChangeLog8
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild15
2 files changed, 14 insertions, 9 deletions
diff --git a/games-misc/sdljoytest/ChangeLog b/games-misc/sdljoytest/ChangeLog
index ee5e1dfc17cf..c303cdb1d4dd 100644
--- a/games-misc/sdljoytest/ChangeLog
+++ b/games-misc/sdljoytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/sdljoytest
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.3 2007/02/08 21:08:24 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.4 2010/06/03 16:10:27 mr_bones_ Exp $
+
+ 03 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ sdljoytest-11102003.ebuild:
+ EAPI=2; add use deps; honor CC; tidy
08 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index cfbe3e213ee7..7bdb399c4109 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.2 2005/07/21 07:52:44 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.3 2010/06/03 16:10:27 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs
DESCRIPTION="SDL app to test joysticks and game controllers"
HOMEPAGE="http://sdljoytest.sourceforge.net/"
@@ -11,15 +14,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="media-libs/libsdl
+DEPEND="media-libs/libsdl[joystick,video]
virtual/opengl
media-libs/sdl-image"
S=${WORKDIR}/SDLJoytest-GL
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
make clean || die "cleaning"
sed -i \
-e 's:/usr/local:/usr:' \
@@ -28,6 +29,7 @@ src_unpack() {
src_compile() {
emake \
+ CC=$(tc-getCC) \
CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}" \
|| die
@@ -38,5 +40,4 @@ src_install() {
insinto /usr/share/SDLJoytest-GL
doins *.bmp || die "data"
doman SDLJoytest.1
- dodoc README
}