summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-apps/xinit/ChangeLog10
-rw-r--r--x11-apps/xinit/files/Xsession.desktop9
-rw-r--r--x11-apps/xinit/xinit-1.3.1-r1.ebuild69
3 files changed, 87 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 65cfd5fecd29..e4f0d5a5f067 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.218 2011/10/03 17:55:53 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.219 2011/11/30 20:10:50 robbat2 Exp $
+
+*xinit-1.3.1-r1 (30 Nov 2011)
+
+ 30 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> +xinit-1.3.1-r1.ebuild,
+ +files/Xsession.desktop:
+ GDM3 looks for .desktop files for the list of possible sessions, whereas GDM2
+ looked at /etc/X11/Sessions/, so put in a .desktop wrapper file pointing to
+ the Xsession script.
03 Oct 2011; Joseph Jezak <josejx@gentoo.org> xinit-1.3.1.ebuild:
Marked ppc ppc64 stable for bug #380421.
diff --git a/x11-apps/xinit/files/Xsession.desktop b/x11-apps/xinit/files/Xsession.desktop
new file mode 100644
index 000000000000..4ed3a5cd8bd9
--- /dev/null
+++ b/x11-apps/xinit/files/Xsession.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=XSession
+Comment=This session logs you into your custom Xsession
+Exec=/etc/X11/Sessions/Xsession
+TryExec=/etc/X11/Sessions/Xsession
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-apps/xinit/xinit-1.3.1-r1.ebuild b/x11-apps/xinit/xinit-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..ce4bab4ed941
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.3.1-r1.ebuild,v 1.1 2011/11/30 20:10:50 robbat2 Exp $
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-customizations.patch"
+ "${FILESDIR}/${P}-prio-process.patch"
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir=/etc/X11/xinit
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/Xsession.desktop"
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}