summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/lame/ChangeLog6
-rw-r--r--media-sound/lame/lame-3.99.3.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 3a4f6e1396cb..bf2c238de101 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.141 2012/01/18 21:28:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.142 2012/01/20 20:32:49 ssuominen Exp $
+
+ 20 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> lame-3.99.3.ebuild:
+ Stop using $(use_enable) for "mmx" because --disable-nasm is broken wrt
+ #361879 by "citiesom" and "Dillon"
18 Jan 2012; Markus Meier <maekke@gentoo.org> lame-3.99.3.ebuild:
arm stable, bug #398353
diff --git a/media-sound/lame/lame-3.99.3.ebuild b/media-sound/lame/lame-3.99.3.ebuild
index a27572f79ac9..7249730f1324 100644
--- a/media-sound/lame/lame-3.99.3.ebuild
+++ b/media-sound/lame/lame-3.99.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.3.ebuild,v 1.4 2012/01/18 21:28:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.3.ebuild,v 1.5 2012/01/20 20:32:49 ssuominen Exp $
EAPI=4
inherit autotools eutils
@@ -29,18 +29,20 @@ src_prepare() {
sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
+ use mmx || sed -i -e '/AC_PATH_PROG/s:nasm:dIsAbLe&:' configure.in #361879
+
AT_M4DIR=${S} eautoreconf
epunt_cxx #74498
}
src_configure() {
local myconf
+ use mmx && myconf="--enable-nasm" #361879
use sndfile && myconf="--with-fileio=sndfile"
econf \
$(use_enable static-libs static) \
$(use_enable debug debug norm) \
- $(use_enable mmx nasm) \
--disable-mp3x \
$(use_enable mp3rtp) \
--enable-dynamic-frontends \