summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pygraphviz/ChangeLog6
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild49
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.1-r2.ebuild40
3 files changed, 5 insertions, 90 deletions
diff --git a/dev-python/pygraphviz/ChangeLog b/dev-python/pygraphviz/ChangeLog
index 12a179b4c278..0cdead4fe2e5 100644
--- a/dev-python/pygraphviz/ChangeLog
+++ b/dev-python/pygraphviz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygraphviz
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/ChangeLog,v 1.20 2015/03/08 23:56:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/ChangeLog,v 1.21 2015/03/27 22:03:47 mrueg Exp $
+
+ 27 Mar 2015; Manuel Rüger <mrueg@gentoo.org> -pygraphviz-1.1-r1.ebuild,
+ -pygraphviz-1.1-r2.ebuild:
+ Remove old.
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> pygraphviz-1.2.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild b/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild
deleted file mode 100644
index 3010fa28a258..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild,v 1.2 2011/08/05 18:05:31 bicatali Exp $
-
-EAPI="3"
-PYTHON_DEPEND=2
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ http://pypi.python.org/pypi/pygraphviz"
-SRC_URI="http://networkx.lanl.gov/download/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-RDEPEND=">=media-gfx/graphviz-2.12"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}"/${PN}-1.0-setup.py.patch
- epatch "${FILESDIR}"/${P}-avoid_tests.patch
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" -c "import sys; sys.path.insert(0, '$(ls -d build-${PYTHON_ABI}/lib.*)'); import pygraphviz.tests; pygraphviz.tests.run()"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/${PN}/tests"
- }
- python_execute_function -q delete_tests
-}
diff --git a/dev-python/pygraphviz/pygraphviz-1.1-r2.ebuild b/dev-python/pygraphviz/pygraphviz-1.1-r2.ebuild
deleted file mode 100644
index eebd59143d88..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.1-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/pygraphviz-1.1-r2.ebuild,v 1.2 2013/04/26 20:45:13 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ http://pypi.python.org/pypi/pygraphviz"
-SRC_URI="http://networkx.lanl.gov/download/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-RDEPEND="media-gfx/graphviz"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0-setup.py.patch
- "${FILESDIR}"/${P}-avoid_tests.patch
-)
-
-python_test() {
- PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
- "${PYTHON}" \
- -c "import pygraphviz.tests; pygraphviz.tests.run()" \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}