summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/claws-mail-spam_report/ChangeLog8
-rw-r--r--mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.16.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/mail-client/claws-mail-spam_report/ChangeLog b/mail-client/claws-mail-spam_report/ChangeLog
index 05337ecd2383..c84d8bd6a8ee 100644
--- a/mail-client/claws-mail-spam_report/ChangeLog
+++ b/mail-client/claws-mail-spam_report/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-spam_report
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-spam_report/ChangeLog,v 1.45 2012/05/04 08:42:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-spam_report/ChangeLog,v 1.46 2012/06/30 16:02:52 fauli Exp $
+
+*claws-mail-spam_report-0.3.16 (30 Jun 2012)
+
+ 30 Jun 2012; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-spam_report-0.3.16.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org>
claws-mail-spam_report-0.3.15.ebuild:
diff --git a/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.16.ebuild b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.16.ebuild
new file mode 100644
index 000000000000..7b4c78b92548
--- /dev/null
+++ b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.16.ebuild,v 1.1 2012/06/30 16:02:52 fauli Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Plugin for Claws to report spam to various places"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.8.1
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+
+ # kill useless files
+ rm -f "${D}"/usr/$(get_libdir)/claws-mail/plugins/*.{a,la}
+}