summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xfractint/ChangeLog9
-rw-r--r--x11-misc/xfractint/xfractint-20.04_p09.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-misc/xfractint/ChangeLog b/x11-misc/xfractint/ChangeLog
index af0a5d7252d1..da50e3b61cf4 100644
--- a/x11-misc/xfractint/ChangeLog
+++ b/x11-misc/xfractint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xfractint
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/ChangeLog,v 1.52 2008/09/14 11:45:32 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/ChangeLog,v 1.53 2008/10/15 17:26:46 spock Exp $
+
+*xfractint-20.04_p09 (15 Oct 2008)
+
+ 15 Oct 2008; Michał Januszewski <spock@gentoo.org>
+ +xfractint-20.04_p09.ebuild:
+ Version bump. Fix the new ebuild so that it respects the user's CFLAGS
+ (bug #241550).
14 Sep 2008; Friedrich Oslage <bluebird@gentoo.org>
xfractint-20.04_p07.ebuild:
diff --git a/x11-misc/xfractint/xfractint-20.04_p09.ebuild b/x11-misc/xfractint/xfractint-20.04_p09.ebuild
new file mode 100644
index 000000000000..4a873fb5ab2f
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.04_p09.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/xfractint-20.04_p09.ebuild,v 1.1 2008/10/15 17:26:46 spock Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="a fractal generator"
+HOMEPAGE="http://www.fractint.org"
+SRC_URI="http://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+# x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # Untested, any x86 archteam dev. is allowed to uncomment this.
+ local myasm="foo"
+# use x86 && myasm="/usr/bin/nasm"
+ emake CC="$(tc-getCC)" AS="${myasm}" OPT="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" STRIP="true" install || die "emake install failed."
+ newenvd "${FILESDIR}"/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+ elog "XFractInt requires the FRACTDIR variable to be set in order to start."
+ elog "Please re-login or \`source /etc/profile\` to have this variable set."
+}