summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/kudzu-knoppix/ChangeLog7
-rw-r--r--sys-apps/kudzu-knoppix/files/kudzu-knoppix-1.1.36-nonls-v4.patch55
-rw-r--r--sys-apps/kudzu-knoppix/files/kudzu.conf.d9
-rw-r--r--sys-apps/kudzu-knoppix/files/kudzu.rc20
-rw-r--r--sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild26
5 files changed, 111 insertions, 6 deletions
diff --git a/sys-apps/kudzu-knoppix/ChangeLog b/sys-apps/kudzu-knoppix/ChangeLog
index 6c16979253ba..655dba03bbef 100644
--- a/sys-apps/kudzu-knoppix/ChangeLog
+++ b/sys-apps/kudzu-knoppix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/kudzu-knoppix
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu-knoppix/ChangeLog,v 1.15 2005/04/06 18:51:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu-knoppix/ChangeLog,v 1.16 2005/05/12 20:00:42 wolf31o2 Exp $
+
+ 12 May 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/kudzu-knoppix-1.1.36-nonls-v4.patch, +files/kudzu.conf.d,
+ +files/kudzu.rc, kudzu-knoppix-1.1.36-r1.ebuild:
+ Added nonls patch and closing bug #89010.
06 Apr 2005; Markus Rothe <corsair@gentoo.org>
kudzu-knoppix-1.1.36-r1.ebuild:
diff --git a/sys-apps/kudzu-knoppix/files/kudzu-knoppix-1.1.36-nonls-v4.patch b/sys-apps/kudzu-knoppix/files/kudzu-knoppix-1.1.36-nonls-v4.patch
new file mode 100644
index 000000000000..231c85da1cb4
--- /dev/null
+++ b/sys-apps/kudzu-knoppix/files/kudzu-knoppix-1.1.36-nonls-v4.patch
@@ -0,0 +1,55 @@
+diff -urp --ignore-space-change kudzu-1.1.36/hwconf.c kudzu-1.1.36-nonls/hwconf.c
+--- kudzu-1.1.36/hwconf.c 2004-01-14 23:58:52.000000000 -0500
++++ kudzu-1.1.36-nonls/hwconf.c 2005-04-14 09:36:46.000000000 -0400
+@@ -26,12 +26,14 @@
+ #include <sys/stat.h>
+ #include <sys/utsname.h>
+
+-#include <libintl.h>
+ #include <locale.h>
+
+ #include <newt.h>
+ #include <popt.h>
+
++#ifndef __USE_GNU_GETTEXT
++#define gettext(String) (String)
++#endif
+ #define _(String) gettext((String))
+ #define N_(String) (String)
+
+@@ -1876,9 +1878,11 @@ int main(int argc, char **argv)
+ { 0, 0, 0, 0, 0, 0 }
+ };
+
++#ifdef __USE_GNU_GETTEXT
+ setlocale(LC_ALL, "");
+ bindtextdomain("kudzu", "/usr/share/locale");
+ textdomain("kudzu");
++#endif
+
+ context = poptGetContext("kudzu", argc, argv, options, 0);
+ while ((rc = poptGetNextOpt(context)) > 0) {
+diff -urp --ignore-space-change kudzu-1.1.36/Makefile kudzu-1.1.36-nonls/Makefile
+--- kudzu-1.1.36/Makefile 2004-01-14 23:58:52.000000000 -0500
++++ kudzu-1.1.36-nonls/Makefile 2005-04-13 13:23:46.000000000 -0400
+@@ -81,10 +81,10 @@ libkudzu.a: $(OBJS) $(VBEOBJS)
+ $(AR) cr libkudzu.a $(OBJS) $(VBEOBJS)
+ $(RANLIB) libkudzu.a
+
+-kudzu: libkudzu.a $(KUDOBJS) po
++kudzu: libkudzu.a $(KUDOBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(KUDOBJS) -o kudzu -L. -lkudzu -L. -lpci -lnewt -lpopt
+
+-updfstab: libkudzu.a updfstab.o po
++updfstab: libkudzu.a updfstab.o
+ $(CC) $(CFLAGS) $(LDFLAGS) updfstab.o -o updfstab -L. -lkudzu -lpci -lpopt
+
+ module_upgrade: libkudzu.a module_upgrade.c
+@@ -129,7 +129,6 @@ install-program: kudzu module_upgrade up
+ for header in $(HEADERS) ; do \
+ install -m 644 $$header $(includedir)/kudzu/$$header ; \
+ done
+- make -C po instroot=$(prefix) install
+
+ install: installdata _kudzumodule.so
+ for ver in $(PYTHONVERS) ; do \
diff --git a/sys-apps/kudzu-knoppix/files/kudzu.conf.d b/sys-apps/kudzu-knoppix/files/kudzu.conf.d
new file mode 100644
index 000000000000..8874c701defd
--- /dev/null
+++ b/sys-apps/kudzu-knoppix/files/kudzu.conf.d
@@ -0,0 +1,9 @@
+# Kudzu configuration
+#
+
+# Below, you can set options
+# The example given is:
+# -s Safe probes ONLY
+# -q Quiet mode
+#KUDZU_OPTS="-s -q"
+
diff --git a/sys-apps/kudzu-knoppix/files/kudzu.rc b/sys-apps/kudzu-knoppix/files/kudzu.rc
new file mode 100644
index 000000000000..4fc13d25d334
--- /dev/null
+++ b/sys-apps/kudzu-knoppix/files/kudzu.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need bootmisc
+}
+
+start() {
+ ebegin "Starting Kudzu"
+ kudzu ${KUDZU_OPTS}
+ # Actually APPLY the settings
+ hwsetup
+ eend $?
+ return 0
+}
+
+stop() {
+ return 0
+}
diff --git a/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild b/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild
index 3f58bc2dd2d2..7d75b00b0d99 100644
--- a/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild
+++ b/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild,v 1.3 2005/04/06 18:51:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu-knoppix/kudzu-knoppix-1.1.36-r1.ebuild,v 1.4 2005/05/12 20:00:42 wolf31o2 Exp $
MY_PV=${PV}-2
S=${WORKDIR}/kudzu-${PV}
@@ -8,10 +8,12 @@ DESCRIPTION="Knoppix version of the Red Hat hardware detection tools"
HOMEPAGE="http://www.knopper.net/"
SRC_URI="http://developer.linuxtag.net/knoppix/sources/${PN}_${MY_PV}.tar.gz"
+inherit eutils
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ppc alpha -sparc -mips ppc64"
-IUSE="livecd"
+IUSE="livecd nls"
RDEPEND="!livecd? ( dev-libs/newt )"
DEPEND="$RDEPEND
@@ -21,14 +23,24 @@ DEPEND="$RDEPEND
!livecd? ( >=dev-libs/dietlibc-0.20 )
!sys-apps/kudzu"
+src_unpack() {
+ unpack ${A}
+ if ! use nls; then
+ epatch "${FILESDIR}/${P}-nonls-v4.patch" || die "epatch failed"
+ fi
+}
+
src_compile() {
+ # Fix the modules directory to match Gentoo layout.
+ perl -pi -e 's|/etc/modutils/kudzu|/etc/modules.d/kudzu|g' *.*
+
if use livecd; then
emake libkudzu.a || die
else
emake || die
fi
- if [ "${ARCH}" = "x86" -o "${ARCH}" = "ppc" ]
+ if use x86 || use ppc
then
cd ddcprobe || die
emake || die
@@ -38,16 +50,20 @@ src_compile() {
src_install() {
if use livecd; then
dodir /etc/sysconfig
- dodir /usr/include/kudzu
insinto /usr/include/kudzu
doins *.h
dolib.a libkudzu.a
else
einstall install-program DESTDIR=${D} PREFIX=/usr \
MANDIR=/usr/share/man || die "Install failed"
+ # Init script isn't appropriate
+ rm -rf ${D}/etc/rc.d
+ # Add our own init scripts
+ newinitd ${FILESDIR}/${PN/-knoppix}.rc ${PN/-knoppix} || die
+ newconfd ${FILESDIR}/${PN/-knoppix}.conf.d ${PN/-knoppix} || die
fi
- if [ "${ARCH}" = "x86" -o "${ARCH}" = "ppc" ]
+ if use x86 || use ppc
then
cd ${S}/ddcprobe || die
dosbin ddcxinfo ddcprobe || die