summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tenshi/tenshi-0.5.1.ebuild')
-rw-r--r--app-admin/tenshi/tenshi-0.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/tenshi/tenshi-0.5.1.ebuild b/app-admin/tenshi/tenshi-0.5.1.ebuild
new file mode 100644
index 000000000000..9787179afb75
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/tenshi-0.5.1.ebuild,v 1.1 2006/06/19 10:34:58 lcars Exp $
+
+inherit eutils
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="http://dev.inversepath.com/trac/tenshi"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.inversepath.com/tenshi/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-apps/coreutils"
+
+pkg_setup() {
+ enewgroup tenshi
+ enewuser tenshi -1 -1 /var/lib/tenshi tenshi
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+ fowners tenshi:root /etc/tenshi/tenshi.conf
+ fowners tenshi:root /var/lib/tenshi
+ doman tenshi.8
+ exeinto /etc/init.d
+ newexe tenshi.gentoo-init tenshi
+ keepdir /var/lib/tenshi
+}