summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/leo/leo-4.2.ebuild')
-rw-r--r--app-editors/leo/leo-4.2.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
index 450d8e4239a6..129a3f7f453f 100644
--- a/app-editors/leo/leo-4.2.ebuild
+++ b/app-editors/leo/leo-4.2.ebuild
@@ -1,26 +1,30 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.6 2005/09/16 03:06:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.7 2007/06/23 09:56:19 hawking Exp $
+
+NEED_PYTHON=2.3
inherit eutils python
MY_P=${P}-final
DESCRIPTION="Leo is an outlining editor and literate programming tool."
HOMEPAGE="http://leo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="PYTHON"
SLOT="0"
KEYWORDS="ppc x86"
IUSE=""
-RDEPEND="virtual/python
- dev-lang/tk"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="app-arch/unzip"
+RDEPEND=""
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ python_tkinter_exists
+}
+
src_unpack() {
unpack ${A}
cd "${S}" || die "Failed to cd ${S}"