summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-7.0_alpha20060205.ebuild')
-rw-r--r--app-editors/vim/vim-7.0_alpha20060205.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.0_alpha20060205.ebuild b/app-editors/vim/vim-7.0_alpha20060205.ebuild
new file mode 100644
index 000000000000..d8471444ddd8
--- /dev/null
+++ b/app-editors/vim/vim-7.0_alpha20060205.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0_alpha20060205.ebuild,v 1.1 2006/02/05 20:42:33 ciaranm Exp $
+
+inherit vim
+
+VIM_DATESTAMP="${PV##*alpha}"
+
+VIM_VERSION="7.0aa"
+VIM_SNAPSHOT="vim-${PV}.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0_alpha20051207-gentoo-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND} !app-editors/nvi
+ !minimal? ( ~app-editors/vim-core-${PV} )"