summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virtinst/virtinst-0.600.0.ebuild')
-rw-r--r--app-emulation/virtinst/virtinst-0.600.0.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-emulation/virtinst/virtinst-0.600.0.ebuild b/app-emulation/virtinst/virtinst-0.600.0.ebuild
index be87ed00952f..800d578460da 100644
--- a/app-emulation/virtinst/virtinst-0.600.0.ebuild
+++ b/app-emulation/virtinst/virtinst-0.600.0.ebuild
@@ -1,20 +1,30 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.600.0.ebuild,v 1.1 2011/07/28 19:18:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.600.0.ebuild,v 1.2 2011/07/28 19:20:30 cardoe Exp $
#BACKPORTS=1
EAPI=3
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="http://git.fedorahosted.org/git/python-virtinst.git"
+ GIT_ECLASS="git-2"
+fi
+
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.*"
SUPPORT_PYTHON_ABIS="1"
-inherit distutils eutils ${HG_ECLASS}
+inherit distutils eutils ${GIT_ECLASS}
-SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
- ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
-KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Python modules for starting virtualized guest installations"
HOMEPAGE="http://virt-manager.et.redhat.com/"