summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/zsnes/zsnes-1.337-r1.ebuild')
-rw-r--r--app-emulation/zsnes/zsnes-1.337-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/zsnes/zsnes-1.337-r1.ebuild b/app-emulation/zsnes/zsnes-1.337-r1.ebuild
new file mode 100644
index 000000000000..57cbdd30ef38
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.337-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/zsnes-1.337-r1.ebuild,v 1.1 2002/04/12 22:53:33 seemant Exp $
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="zsnes is an excellent snes (super nintendo) emulator"
+SRC_URI="http://prdownloads.sourceforge.net/zsnes/zsnes1337src.tar.gz"
+HOMEPAGE="http://www.zsnes.com/"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+
+src_compile() {
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
+}