summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog9
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index e940ed9663e5..79a16a97b603 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.17 2012/12/24 20:28:46 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.18 2013/01/14 20:25:03 cardoe Exp $
+
+*libvirt-glib-0.1.5 (14 Jan 2013)
+
+ 14 Jan 2013; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.1.5.ebuild:
+ Version bump
*libvirt-glib-0.1.4 (24 Dec 2012)
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild
new file mode 100644
index 000000000000..0a4a3767e07e
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild,v 1.1 2013/01/14 20:25:03 cardoe Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+pkg_setup() {
+ G2CONF+="--disable-test-coverage
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+ use python && python-single-r1_pkg_setup
+}