summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/thinkpad/thinkpad-4.1.ebuild')
-rw-r--r--app-laptop/thinkpad/thinkpad-4.1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-laptop/thinkpad/thinkpad-4.1.ebuild b/app-laptop/thinkpad/thinkpad-4.1.ebuild
index 874c9bc37df8..8cc3a8e7287b 100644
--- a/app-laptop/thinkpad/thinkpad-4.1.ebuild
+++ b/app-laptop/thinkpad/thinkpad-4.1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-4.1.ebuild,v 1.3 2004/06/24 22:00:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-4.1.ebuild,v 1.4 2004/06/28 02:37:18 vapier Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control kernel modules"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="x86 amd64 -ppc -mips"
-IUSE=""
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
-#virtual/glibc should depend on specific kernel headers
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A} || die
@@ -34,7 +34,7 @@ src_compile() {
}
src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TECHNOTES
dodir /lib/modules/${KV}/thinkpad
cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
${D}/lib/modules/${KV}/thinkpad
@@ -46,9 +46,5 @@ src_install() {
}
pkg_postinst() {
- /usr/sbin/update-modules || return 0
-}
-
-pkg_prerm() {
- /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+ [ "${ROOT}" == "/" ] && /usr/sbin/update-modules
}