summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/jpilot/jpilot-0.99.7-r1.ebuild')
-rw-r--r--app-pda/jpilot/jpilot-0.99.7-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
index be6f01aea57e..dc7769322c02 100644
--- a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
+++ b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.9 2006/03/28 01:05:50 deltacow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.10 2006/08/29 03:54:47 chriswhite Exp $
inherit eutils multilib
@@ -11,13 +11,12 @@ SRC_URI="http://jpilot.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="nls gtk2"
+IUSE="nls gtk"
-RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
- !gtk2? ( >=x11-libs/gtk+-1.2 )
+RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
>=app-pda/pilot-link-0.11.5"
DEPEND="${RDEPEND}
- gtk2? ( dev-util/pkgconfig )
+ gtk? ( dev-util/pkgconfig )
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -32,7 +31,7 @@ src_unpack() {
}
src_compile() {
- econf $(use_enable gtk2) $(use_enable nls) || die "configure failed"
+ econf $(use_enable gtk gtk2) $(use_enable nls) || die "configure failed"
emake -j1 || die "make failed"
}