summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/mathomatic/mathomatic-11.1c.ebuild')
-rw-r--r--app-sci/mathomatic/mathomatic-11.1c.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-sci/mathomatic/mathomatic-11.1c.ebuild b/app-sci/mathomatic/mathomatic-11.1c.ebuild
new file mode 100644
index 000000000000..bcdda886b825
--- /dev/null
+++ b/app-sci/mathomatic/mathomatic-11.1c.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mathomatic/mathomatic-11.1c.ebuild,v 1.1 2004/05/20 13:31:38 xtv Exp $
+
+DESCRIPTION="Mathomatic - Algebraic Manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tgz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="icc"
+DEPEND="sys-libs/readline \
+ sys-libs/ncurses \
+ icc? ( dev-lang/icc )"
+
+S=${WORKDIR}/am
+
+src_compile() {
+ epatch ${FILESDIR}/gentoo-${P}.diff || die "patching failed"
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake || die "emake failed"
+ else
+ LDFLAGS="-lm" emake || die "emake failed"
+ fi
+
+ make test
+}
+
+src_install() {
+ PREFIX=${D} MANDIR=${D}/usr/share/man einstall || die "einstall failed"
+ dohtml am.htm manual.htm notes.htm
+ newdoc changes.txt CHANGES
+ newdoc lgpl.txt LGPL
+ newdoc readme.txt README
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*in
+}