summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bogosort/bogosort-0.4.2-r1.ebuild')
-rw-r--r--app-text/bogosort/bogosort-0.4.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/bogosort/bogosort-0.4.2-r1.ebuild b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..b1c2c1d3a177
--- /dev/null
+++ b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2-r1.ebuild,v 1.1 2013/05/10 05:47:53 patrick Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A file sorting program which uses the bogosort algorithm"
+HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
+SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/xmalloc.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README NEWS ChangeLog AUTHORS || die
+}