summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cairomm/cairomm-1.10.0.ebuild')
-rw-r--r--dev-cpp/cairomm/cairomm-1.10.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/cairomm-1.10.0.ebuild b/dev-cpp/cairomm/cairomm-1.10.0.ebuild
new file mode 100644
index 000000000000..614e83d280f7
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.10.0.ebuild,v 1.1 2011/09/27 12:59:04 pacho Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/cairomm"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +svg"
+
+# FIXME: svg support is automagic
+RDEPEND=">=x11-libs/cairo-1.10[svg?]
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz )"
+
+src_prepare() {
+ # don't waste time building examples because they are marked as "noinst"
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+
+ # don't waste time building tests
+ # they require the boost Unit Testing framework, that's not in base boost
+ sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-tests \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}