summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/physfs')
-rw-r--r--dev-games/physfs/ChangeLog7
-rw-r--r--dev-games/physfs/files/physfs-2.0.0-gcc44.patch11
-rw-r--r--dev-games/physfs/physfs-2.0.0.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/dev-games/physfs/ChangeLog b/dev-games/physfs/ChangeLog
index f6a312b2fa64..6ae8b2475a8d 100644
--- a/dev-games/physfs/ChangeLog
+++ b/dev-games/physfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/physfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.21 2009/05/24 22:50:07 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.22 2009/05/26 14:59:05 tupone Exp $
+
+ 26 May 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/physfs-2.0.0-gcc44.patch, physfs-2.0.0.ebuild:
+ Remove -Werror, causing build to abort with gcc-4.4.0.
+ Bug #271251 by Robert Forster
*physfs-2.0.0 (24 May 2009)
diff --git a/dev-games/physfs/files/physfs-2.0.0-gcc44.patch b/dev-games/physfs/files/physfs-2.0.0-gcc44.patch
new file mode 100644
index 000000000000..767eea5f40e9
--- /dev/null
+++ b/dev-games/physfs/files/physfs-2.0.0-gcc44.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2009-05-26 16:49:01.000000000 +0200
++++ CMakeLists.txt 2009-05-26 16:49:16.000000000 +0200
+@@ -44,7 +44,7 @@
+ # Add some gcc-specific command lines.
+ IF(CMAKE_COMPILER_IS_GNUCC)
+ # Always build with debug symbols...you can strip it later.
+- ADD_DEFINITIONS(-g -pipe -Werror -fsigned-char)
++ ADD_DEFINITIONS(-g -pipe -fsigned-char)
+
+ # Stupid BeOS generates warnings in the system headers.
+ IF(NOT BEOS)
diff --git a/dev-games/physfs/physfs-2.0.0.ebuild b/dev-games/physfs/physfs-2.0.0.ebuild
index 1206adb911d2..80fcc44f6ffa 100644
--- a/dev-games/physfs/physfs-2.0.0.ebuild
+++ b/dev-games/physfs/physfs-2.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/physfs-2.0.0.ebuild,v 1.1 2009/05/24 22:50:07 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/physfs-2.0.0.ebuild,v 1.2 2009/05/26 14:59:05 tupone Exp $
EAPI=2
-inherit cmake-utils
+inherit eutils cmake-utils
DESCRIPTION="Abstraction layer for filesystem and archive access"
HOMEPAGE="http://icculus.org/physfs/"
@@ -18,6 +18,7 @@ RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
# make sure these libs aren't used
rm -rf lzma zlib*
}