summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haddock/haddock-0.6-r2.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-0.6-r2.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/dev-haskell/haddock/haddock-0.6-r2.ebuild b/dev-haskell/haddock/haddock-0.6-r2.ebuild
index a3090bd419d5..4595afff83ff 100644
--- a/dev-haskell/haddock/haddock-0.6-r2.ebuild
+++ b/dev-haskell/haddock/haddock-0.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.6-r2.ebuild,v 1.12 2005/03/23 14:03:58 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.6-r2.ebuild,v 1.13 2005/09/15 10:39:17 kosmikus Exp $
#
# USE variable summary:
# doc - Build extra documenation from DocBook sources,
@@ -33,6 +33,26 @@ RDEPEND=""
# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
GHCPATH="${PATH}:/opt/ghc/bin"
+pkg_setup() {
+ if ! has_version virtual/ghc; then
+ eerror "Due to a bug in the portage dependency resolution, emerge"
+ eerror "sometimes tries to merge haddock before a version of ghc"
+ eerror "is available on the system. This is usually triggered when"
+ eerror "you try to bootstrap ghc on a system with USE=\"doc\" using"
+ eerror "the command"
+ eerror
+ eerror " emerge ghc"
+ eerror
+ eerror "To resolve this problem, proceed in two steps. First, emerge"
+ eerror "haddock (which should first pull in ghc-bin). Second, emerge"
+ eerror "ghc again:"
+ eerror
+ eerror " emerge haddock"
+ eerror " emerge ghc"
+ die "portage dependency problem"
+ fi
+}
+
src_compile() {
# unset SGML_CATALOG_FILES because documentation installation
# breaks otherwise ...