summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jikes/jikes-1.19.ebuild')
-rw-r--r--dev-java/jikes/jikes-1.19.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/jikes/jikes-1.19.ebuild b/dev-java/jikes/jikes-1.19.ebuild
new file mode 100644
index 000000000000..38be7866b8f0
--- /dev/null
+++ b/dev-java/jikes/jikes-1.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jikes/jikes-1.19.ebuild,v 1.1 2004/02/07 04:33:24 strider Exp $
+
+DESCRIPTION="IBM's open source, high performance Java compiler"
+HOMEPAGE="http://oss.software.ibm.com/developerworks/opensource/jikes/"
+SRC_URI="ftp://www-126.ibm.com/pub/jikes/${PV}/${P}.tar.bz2"
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+RDEPEND="virtual/glibc"
+DEPEND="virtual/jdk"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+ dodoc ChangeLog COPYING AUTHORS README TODO NEWS
+ mv ${D}/usr/doc/${P} ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/doc
+}