summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/spring-core')
-rw-r--r--dev-java/spring-core/ChangeLog7
-rw-r--r--dev-java/spring-core/spring-core-3.2.4.ebuild17
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-java/spring-core/ChangeLog b/dev-java/spring-core/ChangeLog
index 200fb1846472..793bb0d15e3f 100644
--- a/dev-java/spring-core/ChangeLog
+++ b/dev-java/spring-core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/spring-core
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/spring-core/ChangeLog,v 1.1 2013/10/18 16:38:55 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/spring-core/ChangeLog,v 1.2 2015/06/25 09:41:10 monsieurp Exp $
+
+ 25 Jun 2015; Patrice Clement <monsieurp@gentoo.org> spring-core-3.2.4.ebuild:
+ Rearrange test dependencies. Remove a broken test.
*spring-core-3.2.4 (18 Oct 2013)
diff --git a/dev-java/spring-core/spring-core-3.2.4.ebuild b/dev-java/spring-core/spring-core-3.2.4.ebuild
index 6e592c4108b2..88d1ce0bcc5f 100644
--- a/dev-java/spring-core/spring-core-3.2.4.ebuild
+++ b/dev-java/spring-core/spring-core-3.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/spring-core/spring-core-3.2.4.ebuild,v 1.1 2013/10/18 16:38:55 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/spring-core/spring-core-3.2.4.ebuild,v 1.2 2015/06/25 09:41:10 monsieurp Exp $
EAPI="5"
@@ -47,11 +47,17 @@ S="${WORKDIR}/spring-framework-${PV}.RELEASE/"
EANT_BUILD_XML=${S}/${PN}/build.xml
JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="commons-logging,log4j,aspectj,jopt-simple-4.4,asm-4"
+EANT_GENTOO_CLASSPATH="
+ commons-logging
+ log4j
+ aspectj
+ jopt-simple-4.4
+ asm-4"
+
EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH}
hamcrest-library-1.3
hamcrest-core-1.3
- junit
+ junit-4
mockito
xmlunit-1
junit-4"
@@ -61,6 +67,9 @@ java_prepare() {
mkdir "${S}/${PN}/lib/" || die
java-pkg_jar-from --build-only --into "${S}/${PN}/lib/" asm-4
java-pkg_jar-from --build-only --into "${S}/${PN}/lib/" cglib-3 cglib.jar
+
+ # broken test.
+ rm -v ${PN}/src/test/java/org/springframework/core/annotation/AnnotationUtilsTests.java
}
src_install() {