summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.06-r2.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ocaml-3.06-r2.ebuild b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
index d4705ffa6848..470e147c5f71 100644
--- a/dev-lang/ocaml/ocaml-3.06-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.7 2004/07/06 20:51:30 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.8 2004/08/08 09:06:00 mattam Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="x86 sparc ppc alpha"
-IUSE="tcltk"
+IUSE="tcltk latex"
DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
@@ -62,3 +62,9 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+} \ No newline at end of file