summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pike/pike-7.4.28.ebuild')
-rw-r--r--dev-lang/pike/pike-7.4.28.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/pike/pike-7.4.28.ebuild b/dev-lang/pike/pike-7.4.28.ebuild
index de8a19469789..9012b522d941 100644
--- a/dev-lang/pike/pike-7.4.28.ebuild
+++ b/dev-lang/pike/pike-7.4.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc., Emil Skoldberg (see ChangeLog)
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28.ebuild,v 1.7 2003/10/11 17:55:19 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28.ebuild,v 1.8 2003/11/30 22:24:11 scandium Exp $
inherit flag-o-matic
@@ -43,6 +43,9 @@ src_compile() {
}
src_install() {
+ # the installer should be stopped from removing files, to prevent sandbox issues
+ sed -i s/rm\(mod\+\"\.o\"\)\;/\{\}/ ${S}/bin/install.pike || die "Failed to modify install.pike"
+
make INSTALLARGS="--traditional" buildroot="${D}" install || die
if use doc; then