summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.21.ebuild105
-rw-r--r--dev-libs/DirectFB/files/0.9.20-linux-2.6.patch25
-rw-r--r--dev-libs/DirectFB/files/DirectFB-0.9.20-simd-amd64.diff183
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.211
4 files changed, 0 insertions, 314 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.21.ebuild b/dev-libs/DirectFB/DirectFB-0.9.21.ebuild
deleted file mode 100644
index f7ae9a08dc11..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.21.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.21.ebuild,v 1.4 2005/05/05 02:35:04 vapier Exp $
-
-inherit eutils flag-o-matic gcc
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 -mips ppc -sparc x86"
-IUSE="sdl jpeg gif png truetype mpeg mmx sse fusion debug fbcon static"
-
-DEPEND="dev-lang/perl
- sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mpeg? ( media-libs/libmpeg3 )
- truetype? ( >=media-libs/freetype-2.0.1 )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- einfo "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #36924
- sed -i \
- -e 's:wm97xx_ts=yes:wm97xx_ts=no:' configure \
- || die "sed configure failed"
-
-
- # This patch enables simd optimisations for amd64. Since mmx and sse are
- # masked USE flags on amd64 due to their enabling x86 specific asm more
- # often than not, we'll just enable them by default. All x86_64 cpus
- # should support mmx and see. Travis Tilley <lv@gentoo.org>
- use amd64 && epatch "${FILESDIR}"/${PV}-simd-amd64.patch
-}
-
-src_compile() {
- local vidcards card
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="all" \
- || vidcards="${vidcards:1}"
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(gcc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- use mpeg && export CPPFLAGS="${CPPFLAGS} -I/usr/include/libmpeg3"
- econf \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable mpeg libmpeg3) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable static) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- || die
- emake || die
-}
-
-src_install() {
- insinto /etc
- doins fb.modes
-
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
-}
diff --git a/dev-libs/DirectFB/files/0.9.20-linux-2.6.patch b/dev-libs/DirectFB/files/0.9.20-linux-2.6.patch
deleted file mode 100644
index c134be794719..000000000000
--- a/dev-libs/DirectFB/files/0.9.20-linux-2.6.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_v4l.c.orig 2003-12-23 19:23:58.346966040 -0500
-+++ interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_v4l.c 2003-12-23 19:24:26.624667176 -0500
-@@ -27,6 +27,7 @@
- #if defined(__dietlibc__) && !defined(_BSD_SOURCE)
- #define _BSD_SOURCE
- #endif
-+#define _LINUX_TIME_H
-
- #include <stdio.h>
- #include <stdlib.h>
---- gfxdrivers/matrox/matrox_maven.c.orig 2004-03-12 17:26:41.664570688 -0500
-+++ gfxdrivers/matrox/matrox_maven.c 2004-03-12 17:27:42.782279384 -0500
-@@ -29,7 +29,12 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <sys/ioctl.h>
-+#include <linux/version.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
- #include <linux/i2c-dev.h>
-+#else
-+#include <linux/i2c.h>
-+#endif
-
- #include <misc/memcpy.h>
- #include <misc/util.h>
diff --git a/dev-libs/DirectFB/files/DirectFB-0.9.20-simd-amd64.diff b/dev-libs/DirectFB/files/DirectFB-0.9.20-simd-amd64.diff
deleted file mode 100644
index 8755daab0c8e..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-0.9.20-simd-amd64.diff
+++ /dev/null
@@ -1,183 +0,0 @@
-diff -urN DirectFB-0.9.20.orig/src/gfx/generic/generic_mmx.h DirectFB-0.9.20/src/gfx/generic/generic_mmx.h
---- DirectFB-0.9.20.orig/src/gfx/generic/generic_mmx.h 2003-06-30 23:26:04.000000000 +0200
-+++ DirectFB-0.9.20/src/gfx/generic/generic_mmx.h 2004-01-08 23:46:40.000000000 +0100
-@@ -172,15 +172,19 @@
- "movq %%mm1, (%1)\n\t"
- "dec %2\n\t"
- "jz 3f\n\t"
-- "addl $8, %1\n\t"
-- "addl %4, %0\n\t"
-- "testl $0xFFFF0000, %0\n\t"
-+ "add $8, %1\n\t"
-+ "add %4, %0\n\t"
-+ "test $0xFFFF0000, %0\n\t"
- "jz 2b\n\t"
-- "movl %0, %%ebx\n\t"
-- "andl $0xFFFF0000, %%ebx\n\t"
-- "shrl $14, %%ebx\n\t"
-+ "mov %0, %%ebx\n\t"
-+ "and $0xFFFF0000, %%ebx\n\t"
-+ "shr $14, %%ebx\n\t"
-+#ifdef __x86_64__
-+ "add %%rbx, %3\n\t"
-+#else
- "add %%ebx, %3\n\t"
-- "andl $0xFFFF, %0\n\t"
-+#endif
-+ "and $0xFFFF, %0\n\t"
- "jmp 1b\n"
- "3:\n\t"
- "emms"
-@@ -201,8 +205,8 @@
- "movd (%2), %%mm1\n\t"
- "punpcklbw %%mm0, %%mm1\n\t"
- "movq %%mm1, (%0)\n\t"
-- "addl $4, %2\n\t"
-- "addl $8, %0\n\t"
-+ "add $4, %2\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 1b\n\t"
- "emms"
-@@ -238,7 +242,7 @@
- "dec %1\n\t"
- "jz 2f\n\t"
- "psrlq $16, %%mm0\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %0\n\t"
- /* 2. Konvertierung nach 24 bit interleaved */
- "movq %%mm0, %%mm3\n\t"
- "punpcklwd %%mm3, %%mm3\n\t"
-@@ -252,7 +256,7 @@
- "dec %1\n\t"
- "jz 2f\n\t"
- "psrlq $16, %%mm0\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %0\n\t"
- /* 3. Konvertierung nach 24 bit interleaved */
- "movq %%mm0, %%mm3\n\t"
- "punpcklwd %%mm3, %%mm3\n\t"
-@@ -266,7 +270,7 @@
- "dec %1\n\t"
- "jz 2f\n\t"
- "psrlq $16, %%mm0\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %0\n\t"
- /* 4. Konvertierung nach 24 bit interleaved */
- "movq %%mm0, %%mm3\n\t"
- "punpcklwd %%mm3, %%mm3\n\t"
-@@ -279,8 +283,8 @@
- "movq %%mm3, (%0)\n\t"
- "dec %1\n\t"
- "jz 2f\n\t"
-- "addl $8, %0\n\t"
-- "addl $8, %2\n\t"
-+ "add $8, %0\n\t"
-+ "add $8, %2\n\t"
- "jmp 1b\n"
- "2:\n\t"
- "emms"
-@@ -304,8 +308,8 @@
- "punpcklbw %%mm6, %%mm0\n\t"
- "por %%mm7, %%mm0\n\t"
- "movq %%mm0, (%0)\n\t"
-- "addl $4, %2\n\t"
-- "addl $8, %0\n\t"
-+ "add $4, %2\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 1b\n\t"
- "emms"
-@@ -322,7 +326,7 @@
-
- __asm__ __volatile__ (
- "movq %3, %%mm7\n\t"
-- "cmpl $0, %2\n\t"
-+ "cmp $0, %2\n\t"
- "jne 3f\n\t"
- "movq %4, %%mm6\n\t"
- "movd %5, %%mm0\n\t"
-@@ -341,7 +345,7 @@
- "psrlw $8, %%mm0\n\t"
- "movq %%mm0, (%0)\n"
- "1:\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 4b\n\t"
- "jmp 2f\n\t"
-@@ -360,8 +364,8 @@
- "psrlw $8, %%mm0\n\t"
- "movq %%mm0, (%0)\n"
- "1:\n\t"
-- "addl $8, %2\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %2\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 3b\n\t"
- "2:\n\t"
-@@ -379,7 +383,7 @@
-
- __asm__ __volatile__ (
- "movq %3, %%mm7\n\t"
-- "cmpl $0, %2\n\t"
-+ "cmp $0, %2\n\t"
- "jne 3f\n\t"
- "movq %4, %%mm6\n\t"
- "movd %5, %%mm0\n\t"
-@@ -397,7 +401,7 @@
- "psrlw $8, %%mm1\n\t"
- "movq %%mm1, (%0)\n"
- "1:\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 4b\n\t"
- "jmp 2f\n\t"
-@@ -415,8 +419,8 @@
- "psrlw $8, %%mm1\n\t"
- "movq %%mm1, (%0)\n"
- "1:\n\t"
-- "addl $8, %2\n\t"
-- "addl $8, %0\n\t"
-+ "add $8, %2\n\t"
-+ "add $8, %0\n\t"
- "dec %1\n\t"
- "jnz 3b\n\t"
- "2:\n\t"
-diff -urN DirectFB-0.9.20.orig/src/misc/cpu_accel.c DirectFB-0.9.20/src/misc/cpu_accel.c
---- DirectFB-0.9.20.orig/src/misc/cpu_accel.c 2003-08-15 13:32:45.000000000 +0200
-+++ DirectFB-0.9.20/src/misc/cpu_accel.c 2004-01-08 23:48:05.000000000 +0100
-@@ -57,6 +57,13 @@
-
- #include "cpu_accel.h"
-
-+#ifdef __x86_64__
-+static __u32 arch_accel (void)
-+{
-+ return MM_ACCEL_X86_MMX | MM_ACCEL_X86_SSE | MM_ACCEL_X86_MMXEXT | MM_ACCEL_X86_SSE2 | MM_ACCEL_X86_3DNOW;
-+}
-+#endif
-+
- #ifdef ARCH_X86
- static __u32 arch_accel (void)
- {
-@@ -175,7 +182,7 @@
-
- __u32 dfb_mm_accel (void)
- {
--#if defined (ARCH_X86) || (defined (ARCH_PPC) && defined (ENABLE_ALTIVEC))
-+#if defined(__x86_64__) || defined (ARCH_X86) || (defined (ARCH_PPC) && defined (ENABLE_ALTIVEC))
- static __u32 accel = ~0U;
-
- if (accel != ~0U)
-@@ -183,7 +190,7 @@
-
- accel = arch_accel ();
-
--#ifdef USE_SSE
-+#if defined(USE_SSE) && !defined(__x86_64__)
-
- /* test OS support for SSE */
- if (accel & MM_ACCEL_X86_SSE) {
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.21 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.21
deleted file mode 100644
index f99a49df5d8d..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.21
+++ /dev/null
@@ -1 +0,0 @@
-MD5 22699a04f2f618b287aa0ae1b06045b5 DirectFB-0.9.21.tar.gz 1736114