summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/apr-util/apr-util-1.2.12.ebuild')
-rw-r--r--dev-libs/apr-util/apr-util-1.2.12.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/apr-util/apr-util-1.2.12.ebuild b/dev-libs/apr-util/apr-util-1.2.12.ebuild
new file mode 100644
index 000000000000..35d10255b92e
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.2.12.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.12.ebuild,v 1.1 2007/12/15 14:26:31 hollow Exp $
+
+inherit autotools eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz
+ mirror://apache/apr/apr-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb doc gdbm ldap mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+ >=dev-libs/apr-${PV}
+ berkdb? ( =sys-libs/db-4* )
+ doc? ( app-doc/doxygen )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ postgres? ( dev-db/libpq )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ./buildconf --with-apr=../apr-${PV} || die "buildconf failed"
+ elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $(use_with gdbm) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite2) \
+ $(use_with sqlite3) \
+ ${myconf}
+
+ emake || die "emake failed!"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CHANGES NOTICE
+
+ if use doc; then
+ dohtml docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}