summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-2.2.3.ebuild')
-rw-r--r--dev-libs/glib/glib-2.2.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-libs/glib/glib-2.2.3.ebuild b/dev-libs/glib/glib-2.2.3.ebuild
deleted file mode 100644
index 62a51392b7bf..000000000000
--- a/dev-libs/glib/glib-2.2.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.2.3.ebuild,v 1.18 2004/07/02 04:41:59 eradicator Exp $
-
-inherit libtool
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="x86 ppc sparc alpha hppa mips amd64 ia64 s390 ppc64"
-IUSE="doc debug"
-
-DEPEND=">=dev-util/pkgconfig-0.14
- >=sys-devel/gettext-0.11
- doc? ( !s390? ( >=dev-util/gtk-doc-0.9-r2 ) )"
-
-RDEPEND="virtual/libc"
-
-src_compile() {
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug=yes"
-
- econf \
- `use_enable doc gtk-doc` \
- --with-threads=posix \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- einstall || die
-
- # Consider invalid UTF-8 filenames as locale-specific.
- dodir /etc/env.d
- echo "G_BROKEN_FILENAMES=1" > ${D}/etc/env.d/50glib2
-
- dodoc AUTHORS ChangeLog README* INSTALL NEWS NEWS.pre-1-3
-}