summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libev/libev-3.53.ebuild')
-rw-r--r--dev-libs/libev/libev-3.53.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-3.53.ebuild b/dev-libs/libev/libev-3.53.ebuild
new file mode 100644
index 000000000000..0f66c474ebbb
--- /dev/null
+++ b/dev-libs/libev/libev-3.53.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.53.ebuild,v 1.1 2009/02/20 16:18:17 matsuu Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README
+}