summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.0.22.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.0.22.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libxslt/libxslt-1.0.22.ebuild b/dev-libs/libxslt/libxslt-1.0.22.ebuild
new file mode 100644
index 000000000000..f1171764ed7e
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.0.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.22.ebuild,v 1.1 2002/10/28 13:32:30 foser Exp $
+
+inherit libtool gnome.org debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XSLT libraries and tools"
+#SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+
+RDEPEND=">=dev-libs/libxml2-2.4.25"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ econf || die
+ #libxslt-1.0.19 didn't like parallel make; test a good deal before re-enabling
+ #(drobbins, 24 Jul 2002)
+ patch -p0 < ${FILESDIR}/Makefile-py.patch
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}