summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anyvc')
-rw-r--r--dev-python/anyvc/ChangeLog8
-rw-r--r--dev-python/anyvc/anyvc-0.3.3.ebuild51
2 files changed, 56 insertions, 3 deletions
diff --git a/dev-python/anyvc/ChangeLog b/dev-python/anyvc/ChangeLog
index e51f2623701c..24e2fcae7c99 100644
--- a/dev-python/anyvc/ChangeLog
+++ b/dev-python/anyvc/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for dev-python/anyvc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/ChangeLog,v 1.2 2010/09/14 21:42:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/ChangeLog,v 1.3 2010/09/14 21:43:08 arfrever Exp $
+
+*anyvc-0.3.3 (14 Sep 2010)
14 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
- -anyvc-0.3.1.ebuild:
- Delete.
+ -anyvc-0.3.1.ebuild, +anyvc-0.3.3.ebuild:
+ Version bump.
*anyvc-0.3.1 (23 Jun 2010)
diff --git a/dev-python/anyvc/anyvc-0.3.3.ebuild b/dev-python/anyvc/anyvc-0.3.3.ebuild
new file mode 100644
index 000000000000..6f217600b44d
--- /dev/null
+++ b/dev-python/anyvc/anyvc-0.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/anyvc-0.3.3.ebuild,v 1.1 2010/09/14 21:43:08 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Library to access any version control system"
+HOMEPAGE="http://pypi.python.org/pypi/anyvc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar git mercurial subversion"
+# IUSE="bazaar doc git mercurial subversion"
+
+RDEPEND="dev-python/execnet
+ dev-python/py
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-python/dulwich )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-python/subvertpy )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+# doc? ( dev-python/sphinx )
+
+src_compile() {
+ distutils_src_compile
+
+# Documentation fails to build.
+# if use doc; then
+# einfo "Generation of documentation"
+# sphinx-build -b html docs docs_output || die "Generation of documentation failed"
+# fi
+}
+
+src_install() {
+ distutils_src_install
+
+# if use doc; then
+# pushd docs_output > /dev/null
+# docinto html
+# cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+# popd > /dev/null
+# fi
+}