summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django/django-9999.ebuild')
-rw-r--r--dev-python/django/django-9999.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/django/django-9999.ebuild b/dev-python/django/django-9999.ebuild
index ccbd2fc4b23c..ecd83634e5fc 100644
--- a/dev-python/django/django-9999.ebuild
+++ b/dev-python/django/django-9999.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.7 2010/07/06 13:28:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.8 2010/09/22 19:48:23 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit bash-completion distutils subversion webapp
-DESCRIPTION="High-level python web framework"
+DESCRIPTION="High-level Python web framework"
HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
SRC_URI=""
@@ -18,19 +19,12 @@ KEYWORDS=""
IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
- sqlite? ( || (
- >=dev-lang/python-2.5[sqlite]
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- ) )
+ sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
postgres? ( dev-python/psycopg )
mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.3 )
- test? ( || (
- >=dev-lang/python-2.5[sqlite]
- ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
- ) )"
-RESTRICT_PYTHON_ABIS="3.*"
+ test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
S="${WORKDIR}"
@@ -48,8 +42,8 @@ src_compile() {
distutils_src_compile
if use doc; then
- pushd docs > /dev/null
einfo "Generation of documentation"
+ pushd docs > /dev/null
emake html || die "Generation of documentation failed"
popd > /dev/null
fi