summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dnspython/dnspython-1.3.1.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.3.1.ebuild b/dev-python/dnspython/dnspython-1.3.1.ebuild
new file mode 100644
index 000000000000..bbe842f20120
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.3.1.ebuild,v 1.1 2004/07/19 21:55:59 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python."
+HOMEPAGE="http://www.dnspython.org/"
+SRC_URI="http://www.dnspython.org/kits/stable/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=virtual/python-2.2
+ sys-devel/make"
+
+src_install() {
+ distutils_src_install
+ dodoc TODO
+ dodir /usr/share/doc/${P}
+ cp -r examples ${D}/usr/share/doc/${P}
+ dodir /usr/share/${PN}
+ cp -r tests ${D}/usr/share/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is sparse at the moment. Use pydoc,"
+ einfo "or read the HTML documentation at the dnspython home page."
+ einfo
+}
+
+src_test() {
+ export PYTHONPATH="${S}/build/lib:${PYTHONPATH}"
+ cd tests
+ make || die "Unit tests failed!"
+}
+