summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dulwich/dulwich-0.6.0.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.6.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/dulwich/dulwich-0.6.0.ebuild b/dev-python/dulwich/dulwich-0.6.0.ebuild
deleted file mode 100644
index 3e00d748c4e2..000000000000
--- a/dev-python/dulwich/dulwich-0.6.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.6.0.ebuild,v 1.4 2010/07/10 15:26:52 fauli Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
-HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
-SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~ppc-macos ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- sed -e "s/test_check/_&/" -i dulwich/tests/test_objects.py || die "sed failed"
- sed -e "s/test_commit_deleted/_&/" -i dulwich/tests/test_repository.py || die "sed failed"
-}
-
-src_install() {
- distutils_src_install
-
- # Don't install tests.
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
- }
- python_execute_function -q delete_tests
-}