summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-biggles/python-biggles-1.6.5.ebuild')
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-biggles/python-biggles-1.6.5.ebuild b/dev-python/python-biggles/python-biggles-1.6.5.ebuild
new file mode 100644
index 000000000000..77dd90c4f5b1
--- /dev/null
+++ b/dev-python/python-biggles/python-biggles-1.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.5.ebuild,v 1.1 2009/07/14 21:14:07 fauli Exp $
+
+EAPI=2
+
+inherit distutils
+
+MY_P=${P/python/python2}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A Python module for creating publication-quality 2D scientific plots."
+SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
+HOMEPAGE="http://biggles.sourceforge.net/"
+
+DEPEND="media-libs/plotutils[X]
+ dev-python/numpy
+ x11-libs/libSM
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+LICENSE="GPL-2"
+
+PYTHON_MODNAME=biggles
+
+src_install() {
+ distutils_src_install
+
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples/* "${D}/usr/share/doc/${PF}/examples"
+}