summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild')
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild
new file mode 100644
index 000000000000..b04457f38179
--- /dev/null
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.5.ebuild,v 1.1 2009/06/07 23:54:33 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.4"
+
+inherit python
+
+DESCRIPTION="Python bindings for the WebKit GTK+ port."
+HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
+SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2
+ dev-python/pygtk:2
+ dev-python/sexy-python
+ x11-libs/libsexy
+ dev-libs/libxslt
+ >=net-libs/webkit-gtk-1.1.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ python_need_rebuild
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS MAINTAINERS NEWS README || die "dodoc failed"
+}