summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-1.4.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 03edd0f34d5f..db3c6b5b1a38 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.41 2012/10/13 19:00:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.42 2012/11/29 06:20:41 patrick Exp $
+
+*webtest-1.4.3 (29 Nov 2012)
+
+ 29 Nov 2012; Patrick Lauer <patrick@gentoo.org> +webtest-1.4.3.ebuild:
+ Bump
13 Oct 2012; Raúl Porcel <armin76@gentoo.org> webtest-1.2.3.ebuild,
webtest-1.3.ebuild, webtest-1.3.4.ebuild, webtest-1.4.0.ebuild:
diff --git a/dev-python/webtest/webtest-1.4.3.ebuild b/dev-python/webtest/webtest-1.4.3.ebuild
new file mode 100644
index 000000000000..0ecde0d9c94e
--- /dev/null
+++ b/dev-python/webtest/webtest-1.4.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.4.3.ebuild,v 1.1 2012/11/29 06:20:41 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1"
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-python/webob-0.9.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pyquery )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ sphinx-build docs html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
+ delete_lint3() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
+ }
+ python_execute_function -q delete_lint3
+
+ if use doc; then
+ dohtml -r html/*
+ fi
+}